Results 1 to 3 of 3

Thread: Blown ATI x1950 Pro?

  1. #1
    Registered User
    Join Date
    Dec 2003
    Location
    Durham
    Posts
    148
    Thanks
    3
    Thanked
    0 times in 0 posts
    • scottxxx's system
      • Motherboard:
      • Gigabyte 965P-S3
      • CPU:
      • 6320 @ 3.0GHz
      • Memory:
      • 4x1GB DDR2 PC6400
      • Storage:
      • 64GB Crucial RealSSD C300, 500GB Samsung SpinPoint, 1TB Samsung SpinPoint
      • Graphics card(s):
      • MSI 512mb x1950 Pro
      • PSU:
      • Meridian XClio 480W
      • Case:
      • Thermaltake Tsunami Dream
      • Monitor(s):
      • LG 22" L226WTQ-SF & LG W2243
      • Internet:
      • Sky 0.2MB "Up to 8 MB" Broadband

    Blown ATI x1950 Pro?

    Had the following setup for about a month now, everything working flawlessly.

    Intel 6320 @ 3ghz
    2x 1gb Patriot PC6400
    MSI 512mb x1950 pro
    36GB WD Raptor
    250 WD Caviar
    Gigabye 965P-S3 motherboard
    480W XClio PSU

    The graphics card fan was pretty noisy so replaced it with an Arctic Accelero X2, switched the PC on and everything was fine. Graphics card fan was working properly, along with everything else. After a few minutes decided to start up a game, and played for about 10 minutes then the computer just turned off. Wouldn't power back on, so tried removing the graphics card and it turns on ok. Put the graphics card back in and it won't boot - doesn't get as far as posting - CPU fan spins for a split second then everything turns off.

    So I take it my card is fried somehow?

  2. #2
    Senior Member Dreaming's Avatar
    Join Date
    Nov 2006
    Location
    Leicester / York
    Posts
    1,500
    Thanks
    67
    Thanked
    40 times in 30 posts
    • Dreaming's system
      • Motherboard:
      • Abit IP35 Pro
      • CPU:
      • e6300 @ 2.8ghz
      • Memory:
      • 4gb Corsair XMS2 PC6400
      • Storage:
      • 500GB Western Digital for OS + 1500GB Seagate for Storage
      • Graphics card(s):
      • BFG 8800GTS OC2 320MB
      • PSU:
      • Antec Neo HE 550
      • Case:
      • Lian Li PC A05B
      • Operating System:
      • Windows Vista Home Premium x64
      • Monitor(s):
      • Samsung 22" 226BW
      • Internet:
      • NTL 4Mb/s
    The card of death. Look in the ATI forum, in fact any forum on the internet, so many issues relating to this card. See if you can get an RMA and a refund, definately sounds busted. One of the problems of the accelero x2 on this card is that it doesn't cool the VRM chips at the end of the carD (near where the 6 pin power plug is) without any extra heatsinks and stuff.

  3. #3
    Registered User
    Join Date
    Dec 2003
    Location
    Durham
    Posts
    148
    Thanks
    3
    Thanked
    0 times in 0 posts
    • scottxxx's system
      • Motherboard:
      • Gigabyte 965P-S3
      • CPU:
      • 6320 @ 3.0GHz
      • Memory:
      • 4x1GB DDR2 PC6400
      • Storage:
      • 64GB Crucial RealSSD C300, 500GB Samsung SpinPoint, 1TB Samsung SpinPoint
      • Graphics card(s):
      • MSI 512mb x1950 Pro
      • PSU:
      • Meridian XClio 480W
      • Case:
      • Thermaltake Tsunami Dream
      • Monitor(s):
      • LG 22" L226WTQ-SF & LG W2243
      • Internet:
      • Sky 0.2MB "Up to 8 MB" Broadband
    The MSI version has a heatsink on the VRM chips, so the modified plate for the X1950 version of the cooler doesn't need to be fitted, and the VRM chips should be ok since they've got a little heatsink. Didn't realise the card was so problematic though.

    Looks like an RMA job though, and puts my PC out of action until I get a replacement (or my Quadro FX550 from work).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 05-12-2006, 08:48 AM
  2. HEXUS.reviews :: Sapphire Radeon X1950 Pro 256MiB
    By Tarinder in forum HEXUS Reviews
    Replies: 11
    Last Post: 19-11-2006, 03:39 PM
  3. AGP X1950 Pro
    By =TcQi= in forum Graphics Cards
    Replies: 4
    Last Post: 07-11-2006, 08:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •