Results 1 to 12 of 12

Thread: Laptop help

  1. #1
    Senior Member
    Join Date
    Oct 2009
    Location
    Alfreton
    Posts
    323
    Thanks
    31
    Thanked
    18 times in 18 posts
    • cub1061's system
      • Motherboard:
      • Asrock B250M Pro
      • CPU:
      • Intel i7 6700k
      • Memory:
      • 16gb ddr4
      • Storage:
      • 240 ssd + 2x1gb Seagate
      • Graphics card(s):
      • EVGA 1060 6gb
      • PSU:
      • BeQuite 630w
      • Case:
      • Fractal Define Mini C
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • AOC 27"
      • Internet:
      • Snail speed

    Laptop help

    My trusted Dell D620 has gone on the blink. Used it last night to surf the net and all was fine.
    Came to use it tonight and the screen started to become distorted with fuzzy shapes on windows start up and main window feels like I am viewing through a filter.

    My first thought was that the nvidia graphic chip has over heated and started to die so to double check i connected to my tv and the screen was perfect.

    So question is.

    What has die? Is the screen dying or is it something else.

    Any advice welcome.

  2. #2
    Goron goron Kumagoro's Avatar
    Join Date
    Mar 2004
    Posts
    3,000
    Thanks
    20
    Thanked
    138 times in 112 posts

    Re: Laptop help

    Most likely the screen but the connector could have come loose

  3. #3
    Going Retro!!! Ferral's Avatar
    Join Date
    Jul 2003
    Location
    North East
    Posts
    7,585
    Thanks
    454
    Thanked
    1,166 times in 744 posts
    • Ferral's system
      • Motherboard:
      • ASUS Z97-P
      • CPU:
      • Intel i7 4790K Haswell
      • Memory:
      • 8Gb Corsair XMS3 DDR3 1600 Mhz
      • Storage:
      • 120Gb Kingston SSD & 1.5 Tb Western Digital
      • Graphics card(s):
      • Sapphire Radeon R9 380 Nitro 4Gb
      • PSU:
      • Antec Truepower 750 Watt Modular
      • Case:
      • Zalman HD501 HTPC case
      • Operating System:
      • Windows 10 64 bit
      • Monitor(s):
      • 21" ASUS 1080P Widescreen LCD
      • Internet:
      • 20MB Sky Fibre

    Re: Laptop help

    Could possibly be a driver issue. Get the latest mobile driver from the Nvidia site but before installing it do a full uninstall of the current driver and clean with driver sweeper.

    http://www.phyxion.net for driver sweeper

  4. #4
    Senior Member
    Join Date
    Oct 2009
    Location
    Alfreton
    Posts
    323
    Thanks
    31
    Thanked
    18 times in 18 posts
    • cub1061's system
      • Motherboard:
      • Asrock B250M Pro
      • CPU:
      • Intel i7 6700k
      • Memory:
      • 16gb ddr4
      • Storage:
      • 240 ssd + 2x1gb Seagate
      • Graphics card(s):
      • EVGA 1060 6gb
      • PSU:
      • BeQuite 630w
      • Case:
      • Fractal Define Mini C
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • AOC 27"
      • Internet:
      • Snail speed

    Re: Laptop help

    Quote Originally Posted by Kumagoro View Post
    Most likely the screen but the connector could have come loose
    Have taken it apart and check connectors at both ends, no different.

  5. #5
    OilSheikh
    Guest

    Re: Laptop help

    How long have you had the laptop for ?

  6. #6
    Senior Member
    Join Date
    Oct 2009
    Location
    Alfreton
    Posts
    323
    Thanks
    31
    Thanked
    18 times in 18 posts
    • cub1061's system
      • Motherboard:
      • Asrock B250M Pro
      • CPU:
      • Intel i7 6700k
      • Memory:
      • 16gb ddr4
      • Storage:
      • 240 ssd + 2x1gb Seagate
      • Graphics card(s):
      • EVGA 1060 6gb
      • PSU:
      • BeQuite 630w
      • Case:
      • Fractal Define Mini C
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • AOC 27"
      • Internet:
      • Snail speed

    Re: Laptop help

    Check drivers and got most up to date version, have had the laptop for 2 years now

  7. #7
    Senior Member
    Join Date
    Oct 2009
    Location
    Alfreton
    Posts
    323
    Thanks
    31
    Thanked
    18 times in 18 posts
    • cub1061's system
      • Motherboard:
      • Asrock B250M Pro
      • CPU:
      • Intel i7 6700k
      • Memory:
      • 16gb ddr4
      • Storage:
      • 240 ssd + 2x1gb Seagate
      • Graphics card(s):
      • EVGA 1060 6gb
      • PSU:
      • BeQuite 630w
      • Case:
      • Fractal Define Mini C
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • AOC 27"
      • Internet:
      • Snail speed

    Re: Laptop help

    I am even more confussed now, did a screen print of the fuzzy screen and transfered on to the pc.
    The image which can out was fine, now I am think have I missed something while checking the connectors or had the screen gone.

    Photo of screen


    Screenshot image


    Is it the screen or connectors?

  8. #8
    Senior Member
    Join Date
    Oct 2009
    Location
    Alfreton
    Posts
    323
    Thanks
    31
    Thanked
    18 times in 18 posts
    • cub1061's system
      • Motherboard:
      • Asrock B250M Pro
      • CPU:
      • Intel i7 6700k
      • Memory:
      • 16gb ddr4
      • Storage:
      • 240 ssd + 2x1gb Seagate
      • Graphics card(s):
      • EVGA 1060 6gb
      • PSU:
      • BeQuite 630w
      • Case:
      • Fractal Define Mini C
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • AOC 27"
      • Internet:
      • Snail speed

    Re: Laptop help

    Bump

  9. #9
    Going Retro!!! Ferral's Avatar
    Join Date
    Jul 2003
    Location
    North East
    Posts
    7,585
    Thanks
    454
    Thanked
    1,166 times in 744 posts
    • Ferral's system
      • Motherboard:
      • ASUS Z97-P
      • CPU:
      • Intel i7 4790K Haswell
      • Memory:
      • 8Gb Corsair XMS3 DDR3 1600 Mhz
      • Storage:
      • 120Gb Kingston SSD & 1.5 Tb Western Digital
      • Graphics card(s):
      • Sapphire Radeon R9 380 Nitro 4Gb
      • PSU:
      • Antec Truepower 750 Watt Modular
      • Case:
      • Zalman HD501 HTPC case
      • Operating System:
      • Windows 10 64 bit
      • Monitor(s):
      • 21" ASUS 1080P Widescreen LCD
      • Internet:
      • 20MB Sky Fibre

    Re: Laptop help

    Looking at the screenshots that looks like the dedicated ram for the nvidia chip.

    Have you got a few games installed to test? See if you get anomalies like random spikes etc whilst playing. If you have no games installed grab Steam and create an account, they have few free games on there like Team Fortress 2 and there are also a few free to play MMO games. Makes testing a bit easier. Test with stuff that needs 3D acceleration.

    With my GeForce 560 Ti that I had to rma I was getting weird patters on my desktop but during games I was getting those weird pink swirls on bright colours and also spikes coming out from objects and flashing. Turned out to be the cards ram causing the issue.

    This is what I was getting with my vram fault :




  10. #10
    Alpha
    Join Date
    Jun 2008
    Location
    London
    Posts
    355
    Thanks
    26
    Thanked
    7 times in 6 posts
    • Nelsaidi's system
      • Motherboard:
      • Asus P5Qe IP45
      • CPU:
      • Intel E8400
      • Memory:
      • 2x2Gb Corsair PC2-6400
      • Storage:
      • Western Digital Caviar SE16 640Gb 7200rpm, Seagate 250gb 7200rpm
      • Graphics card(s):
      • Sapphire HD4850 512mb
      • PSU:
      • Corsair HX 520w
      • Case:
      • Antec 300
      • Operating System:
      • Windows 7
      • Monitor(s):
      • DEll Ultrasharp 17"
      • Internet:
      • AOL :(

    Re: Laptop help

    // Wrong post - delete :/

  11. #11
    Senior Member
    Join Date
    Oct 2009
    Location
    Alfreton
    Posts
    323
    Thanks
    31
    Thanked
    18 times in 18 posts
    • cub1061's system
      • Motherboard:
      • Asrock B250M Pro
      • CPU:
      • Intel i7 6700k
      • Memory:
      • 16gb ddr4
      • Storage:
      • 240 ssd + 2x1gb Seagate
      • Graphics card(s):
      • EVGA 1060 6gb
      • PSU:
      • BeQuite 630w
      • Case:
      • Fractal Define Mini C
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • AOC 27"
      • Internet:
      • Snail speed

    Re: Laptop help

    Quote Originally Posted by Ferral View Post
    Looking at the screenshots that looks like the dedicated ram for the nvidia chip.

    Have you got a few games installed to test? See if you get anomalies like random spikes etc whilst playing. If you have no games installed grab Steam and create an account, they have few free games on there like Team Fortress 2 and there are also a few free to play MMO games. Makes testing a bit easier. Test with stuff that needs 3D acceleration.
    I ran 3D mark 05 and I can't even make out the image. Connecting to an external screen and it ran fine.

    What does the inverter do?
    Could this affect the screen?

  12. #12
    Going Retro!!! Ferral's Avatar
    Join Date
    Jul 2003
    Location
    North East
    Posts
    7,585
    Thanks
    454
    Thanked
    1,166 times in 744 posts
    • Ferral's system
      • Motherboard:
      • ASUS Z97-P
      • CPU:
      • Intel i7 4790K Haswell
      • Memory:
      • 8Gb Corsair XMS3 DDR3 1600 Mhz
      • Storage:
      • 120Gb Kingston SSD & 1.5 Tb Western Digital
      • Graphics card(s):
      • Sapphire Radeon R9 380 Nitro 4Gb
      • PSU:
      • Antec Truepower 750 Watt Modular
      • Case:
      • Zalman HD501 HTPC case
      • Operating System:
      • Windows 10 64 bit
      • Monitor(s):
      • 21" ASUS 1080P Widescreen LCD
      • Internet:
      • 20MB Sky Fibre

    Re: Laptop help

    In that case not entirely sure what it would be. If it is working fine connected to a different screen the nvidia chip its ram and d sub output is fine.

    Could possibly be the ribbon cable that connects the laptop screen to the mainboard. Could have come loose from the board or the cable itself could be damaged with it bending / flexing for the last few years, general wear and tear type thing. Trouble is these ribbon cables are usually permanently attached to the screen itself and connector for motherboard side.

    If you have done full driver re install etc this could well be a screen fault of some sort

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 05-07-2012, 04:07 PM
  2. Any tips & tricks for getting a Dell laptop cheaper?
    By Andeh13 in forum PC Hardware and Components
    Replies: 13
    Last Post: 13-04-2009, 11:59 AM
  3. Laptop Advice
    By WLC-1989 in forum PC Hardware and Components
    Replies: 3
    Last Post: 01-09-2006, 06:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •