Results 1 to 6 of 6

Thread: No Sound on HDMI Output from AMD GPU

  1. #1
    Senior Member
    Join Date
    Jan 2013
    Location
    West Sussex
    Posts
    530
    Thanks
    50
    Thanked
    44 times in 33 posts
    • Chadders87's system
      • Motherboard:
      • Asus P8Z77-I Deluxe
      • CPU:
      • Intel i5 3570k
      • Memory:
      • Corsair Vengeance 8GB (2x4GB) 1600mhz
      • Storage:
      • Western Digital Caviar Black 1TB (Sata3)
      • Graphics card(s):
      • Sapphire AMD Radeon 7870 2GB
      • PSU:
      • BeQuiet 450w (140mm)
      • Case:
      • BitFenix Prodigy
      • Operating System:
      • Windows 7 Home Premium
      • Monitor(s):
      • Samsung 21.5'
      • Internet:
      • Sky Unlimited

    No Sound on HDMI Output from AMD GPU

    HI,

    I use an AMD 7870 HD gpu and have the TV set up through the HDMI output. The PC monitor goes through the usual DVI and I switch between the 2 outputs dependent on what I am doing. The Monitor Audio is output from the motherboard (Asus P8Z77-I Deluxe).

    The issue is that every time I switch from Monitor (DVI) to the TV (HDMI) I have to go into device manager and uninstall / disable the onboard windows sound drivers and restart the PC before the audio output recognises the TV as a valid option.

    I have the latest version of Catalyst and am running windows 7 64bit.

    Any help is appreciated as this is beginning to frustrate me to no end as I can't find a solution anywhere.


    ~Ian

  2. #2
    Snr Mbr I ain't that old
    Join Date
    May 2013
    Location
    Worcester, UK
    Posts
    269
    Thanks
    115
    Thanked
    35 times in 33 posts
    • aramil's system
      • Motherboard:
      • ASUS Sabertooth Z77
      • CPU:
      • Intel i5-3570k delided CLU XSPC-Raystorm
      • Memory:
      • corsair vengeance 16Gb
      • Storage:
      • Samsung 840 evo 250 Gb
      • Graphics card(s):
      • Palit GeForce GTX 980 Super Jetstream
      • PSU:
      • corsair tx750 v2
      • Case:
      • Zalman MS800
      • Operating System:
      • MS Windows 10 Pro 64 bit
      • Monitor(s):
      • AOC 27" 2560x1440
      • Internet:
      • 75-down 17-up

    Re: No Sound on HDMI Output from AMD GPU

    Can't you just change the sound output device by bringing up the sound properties from the taskbar?
    Intel i7 8700K delidded | Asus TUF Z370 Gaming Plus | Palit GTX980 SuperJetStream 4Gb | Samsung 840 EVO 240Gb | Samsung 1Tb F2 | WD 1Tb & 2Tb | Corsair 750TX v2 | 32Gb Corsair Vengence | Saitek Cyborg EVO F.S. | Zalman MS800 | Corsair K90 | AOC 27" 2560x1440 |AOC 24" HD | HTC Vive
    “This post was written using 100% recycled words.”

  3. #3
    Senior Member
    Join Date
    Jan 2013
    Location
    West Sussex
    Posts
    530
    Thanks
    50
    Thanked
    44 times in 33 posts
    • Chadders87's system
      • Motherboard:
      • Asus P8Z77-I Deluxe
      • CPU:
      • Intel i5 3570k
      • Memory:
      • Corsair Vengeance 8GB (2x4GB) 1600mhz
      • Storage:
      • Western Digital Caviar Black 1TB (Sata3)
      • Graphics card(s):
      • Sapphire AMD Radeon 7870 2GB
      • PSU:
      • BeQuiet 450w (140mm)
      • Case:
      • BitFenix Prodigy
      • Operating System:
      • Windows 7 Home Premium
      • Monitor(s):
      • Samsung 21.5'
      • Internet:
      • Sky Unlimited

    Re: No Sound on HDMI Output from AMD GPU

    In the sound properties, the TV is greyed out and listed as "Not Detected" until I either uninstall or disable the motherboards onboard sound driver and restart the machine.

    This will then give priority to the AMD HDMI Audio driver and allows the TV to be selected as the sound output device. Funnily enough, if I then switch back to the Monitor, windows will automatically reinstall / enable the onboard drivers and let me switch back to the monitor speakers without fuss.

  4. #4
    Bah Humbug. Dooms's Avatar
    Join Date
    Jan 2005
    Location
    Brixton
    Posts
    3,325
    Thanks
    94
    Thanked
    183 times in 141 posts
    • Dooms's system
      • Motherboard:
      • MSI Z97i Gaming ACK
      • CPU:
      • i7 4790K @ 4.4Ghz
      • Memory:
      • Corsair 16GB Vengeance
      • Storage:
      • 500Gb Samsung 840 SSD & 960GB Kingston SSD
      • Graphics card(s):
      • Zotac 1080
      • PSU:
      • 750W Corsair Pro
      • Case:
      • Phanteks Evolv ITX
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • LG 34UC88 34-Inch 21:9
      • Internet:
      • Virgin 220MB

    Re: No Sound on HDMI Output from AMD GPU

    You can passthru the stero mix and have both Speaker and HDMI audio running at the same time (which will only do HDMI if the TV is on and on the correct channel obivously. Its what I do.

    It took some time searching around but I finally managed to find an answer by myself, I'm posting the solution here in case anyone has a similar issue:

    Open Sound panel
    Select Speakers as the default playback device
    Go to the "Recording" tab
    Right click and enable "Show Disabled Devices"
    A recording device called "Wave Out Mix", "Mono Mix" or "Stereo Mix" (this was my case) should appear
    Right click on the new device and click "Enable"
    Right click on the new device and click "Set as Default Device"
    Double click on the new device to open the Properties window
    Go to the "Listen" tab
    Click on the "Listen to this device" checkbox
    Select your HDMI device from the "Playback through this device" list
    And you're done, the drawback is that you won't have a microphone selected as default recording device, but for what concerns me I couldn't care less.
    http://answers.microsoft.com/en-us/w...2-eff594a9ae49

  5. Received thanks from:

    Chadders87 (22-08-2013)

  6. #5
    Bah Humbug. Dooms's Avatar
    Join Date
    Jan 2005
    Location
    Brixton
    Posts
    3,325
    Thanks
    94
    Thanked
    183 times in 141 posts
    • Dooms's system
      • Motherboard:
      • MSI Z97i Gaming ACK
      • CPU:
      • i7 4790K @ 4.4Ghz
      • Memory:
      • Corsair 16GB Vengeance
      • Storage:
      • 500Gb Samsung 840 SSD & 960GB Kingston SSD
      • Graphics card(s):
      • Zotac 1080
      • PSU:
      • 750W Corsair Pro
      • Case:
      • Phanteks Evolv ITX
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • LG 34UC88 34-Inch 21:9
      • Internet:
      • Virgin 220MB

    Re: No Sound on HDMI Output from AMD GPU

    Ah sounds like you are having other issues related to drivers so the solution I posted may not help.

  7. #6
    Senior Member
    Join Date
    Jan 2013
    Location
    West Sussex
    Posts
    530
    Thanks
    50
    Thanked
    44 times in 33 posts
    • Chadders87's system
      • Motherboard:
      • Asus P8Z77-I Deluxe
      • CPU:
      • Intel i5 3570k
      • Memory:
      • Corsair Vengeance 8GB (2x4GB) 1600mhz
      • Storage:
      • Western Digital Caviar Black 1TB (Sata3)
      • Graphics card(s):
      • Sapphire AMD Radeon 7870 2GB
      • PSU:
      • BeQuiet 450w (140mm)
      • Case:
      • BitFenix Prodigy
      • Operating System:
      • Windows 7 Home Premium
      • Monitor(s):
      • Samsung 21.5'
      • Internet:
      • Sky Unlimited

    Re: No Sound on HDMI Output from AMD GPU

    Thanks Dooms, Looks like it may work in theory so will give it a go tonight.

    The driver issue is only that windows recognises it's own as a higher priority and overrules all others, requiring it to be removed for other drivers to be "seen" by the system.

    Edit: no luck on this solution. There's no options for Mono / Stereo on my Recordings box.
    Last edited by Chadders87; 22-08-2013 at 07:00 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •