Results 1 to 2 of 2

Thread: epson perfection 1260 mains lead

  1. #1
    Thundercats Ho! starbuck's Avatar
    Join Date
    Feb 2004
    Location
    Portsmouth
    Posts
    1,327
    Thanks
    9
    Thanked
    29 times in 19 posts
    • starbuck's system
      • Motherboard:
      • P5K Deluxe Wi-Fi
      • CPU:
      • E6600
      • Memory:
      • 4gb
      • Storage:
      • 2x500gb Samsung spinpoint in raid 0, 320gb diamondmax SATA
      • Graphics card(s):
      • GT240
      • PSU:
      • Enermax Galaxy 850watt
      • Case:
      • Silverstone TJ05
      • Operating System:
      • Windows 7 Home Premium
      • Monitor(s):
      • 20" Dell(rebadged sony) trinitron CRT
      • Internet:
      • 20mb cable internet connection

    epson perfection 1260 mains lead

    need a mains lead for this but cannot find an adapter anywhere. It needs 15.2v @ 1.2amp. Tried maplins who don't have one, cannot find anything on epson's website either. any ideas?
    I do know everything, just not all at once. It's a virtual memory problem.

  2. #2
    Banned Shogun's Avatar
    Join Date
    Feb 2004
    Location
    Redditch, West Midlands
    Posts
    2,396
    Thanks
    0
    Thanked
    0 times in 0 posts
    Tried emailing them?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •