Results 1 to 12 of 12

Thread: Unable to terminate process... "Access Denied".

  1. #1
    Banned
    Join Date
    Jul 2004
    Location
    Blackpool
    Posts
    983
    Thanks
    15
    Thanked
    38 times in 20 posts

    Unable to terminate process... "Access Denied".

    Okay, got a little bit of an annoying problem here, i'm thinking it has been caused by spyware changing my rights to protect itself. I've done a full scan and cleared everything with both AdAware and Spybot but it's still happening.

    When i go into task manager and attempt to kill any process owned by "System" (As opposed to a program being ran by me), it simply throws me an access denied error. I booted to a fresh install of XP i have on another partition and I can close the same processes no problem.

    Anyone have any ideas how I can fix this? Any security settings in the registry or Administrative tools that i can change back to what theys hould be?

    I've googled this but not much luck in fixing it.


    Oh, and another problem i'm getting every so often is when i leave my PC for a few hours, or play a game, I can come back and find an icon in my systemtray telling me that my network connection has limited/no connectivity, and i have to reboot to be able to access the internet. Googling shows this to be a problem with SP2 but it's only started happening since i got a crapload of spyware attacking me. Again, any ideas?

    Thanks.

  2. #2
    Oh no!I've re-dorkalated! Jiff Lemon's Avatar
    Join Date
    Jul 2003
    Location
    Sunny MK
    Posts
    2,504
    Thanks
    80
    Thanked
    44 times in 41 posts
    Whats the process you're trying to kill?

  3. #3
    Banned
    Join Date
    Jul 2004
    Location
    Blackpool
    Posts
    983
    Thanks
    15
    Thanked
    38 times in 20 posts


    Any of the circled. Anything that is under the name of "System". As i said these can all be closed using a freshly installed XP, so some settings somewhere are b0rked i think. Thanks.

  4. #4
    Oh no!I've re-dorkalated! Jiff Lemon's Avatar
    Join Date
    Jul 2003
    Location
    Sunny MK
    Posts
    2,504
    Thanks
    80
    Thanked
    44 times in 41 posts
    errr..... You don't want to try an terminate those.

    System idle process - A dummy process used when nothing is happening
    Spoolsv - the print spooler service. Use services to stop it, but you'll not be able to print.
    Smss.exe - This is the session manager subsystem, which is responsible for starting the user session. This process is initiated by the system thread and is responsible for various activities, including launching the Winlogon (winlogon.exe) and Win32 (Csrss.exe) processes and setting system variables.
    btwdins.exe - Microsoft's bluetooth service.

  5. #5
    Banned
    Join Date
    Jul 2004
    Location
    Blackpool
    Posts
    983
    Thanks
    15
    Thanked
    38 times in 20 posts
    Yes but i usually (Before the spyware problems) had services like "WinAdSvc.exe" starting as a system process which I couldn't end. And should this happen again i want to be able to kill it. Not only that it's affecting something else...

    When i try to play wolfenstein E.T. with punkbuster enabled i get disconnected from servers after like 30 seconds due to punkbuster being unable to do it's job. I get an error along the lines of "Insufficient O/S privilege". When i googled this it came up with results of how some spyware alters the admin priveleges of your account, which i think has tied in with this. Really beginning to suck

  6. #6
    Senior Member
    Join Date
    Jul 2003
    Posts
    413
    Thanks
    0
    Thanked
    0 times in 0 posts
    That has nothing to do with the processes circled, those processes as already explained need to run.
    Bored of the old one, new one coming soon

  7. #7
    Senior Member ajbrun's Avatar
    Join Date
    Apr 2004
    Location
    York, England
    Posts
    4,840
    Thanks
    4
    Thanked
    25 times in 13 posts
    Well, I'm guessing you already have these programs:
    * spybot
    * ad-aware
    * anti virus
    * firewall

    As said above, you need al those programs run by "system". I'm not sure about you "connection" problem though. Run every program you have. Even do a defrag and stuff like that. If it's still there when you've done that, then come back with more details.

  8. #8
    Senior Amoeba iranu's Avatar
    Join Date
    Oct 2003
    Location
    On the dinner table. Blechh!
    Posts
    3,532
    Thanks
    111
    Thanked
    156 times in 106 posts
    • iranu's system
      • Motherboard:
      • Asus Maximus Gene VI
      • CPU:
      • 4670K @4.3Ghz
      • Memory:
      • 8Gb Samsung Green
      • Storage:
      • 1x 256Gb Samsung 830 SSD 2x640gb HGST raid 0
      • Graphics card(s):
      • MSI R9 390
      • PSU:
      • Corsair HX620W Modular
      • Case:
      • Cooler Master Silencio 352
      • Operating System:
      • Win 7 ultimate 64 bit
      • Monitor(s):
      • 23" DELL Ultrasharp U2312HM
      • Internet:
      • 16mb broadband
    For the limited/no connectivity bug in sp2 I think you need this hotfix.

    http://www.microsoft.com/downloads/d...displaylang=en

    I had a similar issue and this fixed it.

  9. #9
    Registered User
    Join Date
    Oct 2007
    Posts
    6
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Unable to terminate process... "Access Denied".

    I had a 'Access Denied' problem too

    I solved with my program and I distributed it for anyone.

    If you need it you can find here: <removed>
    Last edited by Agent; 26-10-2007 at 09:26 PM.

  10. #10
    Senior Member ajbrun's Avatar
    Join Date
    Apr 2004
    Location
    York, England
    Posts
    4,840
    Thanks
    4
    Thanked
    25 times in 13 posts

    Re: Unable to terminate process... "Access Denied".

    Quote Originally Posted by AlexMark View Post
    I had a 'Access Denied' problem too

    I solved with my program and I distributed it for anyone.

    If you need it you can find here: [url=www.hexus.net[/url]
    Do you realise you just resurrected a thread that's been dead for almost three years? XP SP2 had only been released 3 months at the time this thread was made - he's probably gone and moved on to vista now...
    Last edited by MD; 28-10-2007 at 10:00 AM.

  11. #11
    Senior Amoeba iranu's Avatar
    Join Date
    Oct 2003
    Location
    On the dinner table. Blechh!
    Posts
    3,532
    Thanks
    111
    Thanked
    156 times in 106 posts
    • iranu's system
      • Motherboard:
      • Asus Maximus Gene VI
      • CPU:
      • 4670K @4.3Ghz
      • Memory:
      • 8Gb Samsung Green
      • Storage:
      • 1x 256Gb Samsung 830 SSD 2x640gb HGST raid 0
      • Graphics card(s):
      • MSI R9 390
      • PSU:
      • Corsair HX620W Modular
      • Case:
      • Cooler Master Silencio 352
      • Operating System:
      • Win 7 ultimate 64 bit
      • Monitor(s):
      • 23" DELL Ultrasharp U2312HM
      • Internet:
      • 16mb broadband

    Re: Unable to terminate process... "Access Denied".

    Quote Originally Posted by ajbrun View Post
    Do you realise you just resurrected a thread that's been dead for almost three years? XP SP2 had only been released 3 months at the time this thread was made - he's probably gone and moved on to vista now...
    and back to XP
    "Reality is what it is, not what you want it to be." Frank Zappa. ----------- "The invisible and the non-existent look very much alike." Huang Po.----------- "A drowsy line of wasted time bathes my open mind", - Ride.

  12. #12
    Senior Member
    Join Date
    Mar 2006
    Location
    London
    Posts
    296
    Thanks
    16
    Thanked
    8 times in 7 posts

    Re: Unable to terminate process... "Access Denied".

    holy thread resurrection, batman

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •