Results 1 to 3 of 3

Thread: Toshiba Laptop Repair

  1. #1
    Richard Allen Evans mr_anderson187's Avatar
    Join Date
    Dec 2003
    Norfolk 'n chance
    0 times in 0 posts

    Toshiba Laptop Repair

    Last year (september 2005 to be precise) i bought myself a laptop, this is the exact model i have. Cost me £280 from a Cash converter shop (type of pawn shop.) Yeah i know buying Computer hardware from a Pawn shop isnt the wisest Idea in the world, but i checked it out thoroughly first, In great condition with all the manuals, drivers and leads that were required, and even came with a carry case, been working great ever since i got it up until last week, when it all went south.

    A few weeks previous to its untimely end there were a number of small clicks coming from the hard hard drive every now and then, it had been on for serious prolonged lengths of time.

    Last week, it froze up on me while i was browsing (a rare occurence, it was usually very stable) and when i tried to reboot it, it restarted, flashed the "TOSHIBA" Post screen at me, then went to a black screen with the text

    A disk read error has occured

    Press Ctrl+Alt+Del to restart
    All the while when its powering-on and sitting at this screen the Hard disk is CLICK CLICK CLICK'ing away.

    So i openeed up the HDD enclosure after leaving it for a while re-fitting the battery, etc etc, and find the Hard disk physically still in shape, but shock horror, its an IBM "Travelstar," i was unlucky enough to have an IBM "Deskstar" nicknamed "Deathstar" because of the startlingly high mortality rate and yeah it died on me and took a lot of precious data with it, in a hail of Clicking and failing.

    In my infinite wisdom i decided to leave the manuals driver CD and restore CD at home when i came to university this year, so far i havent had any problems with it, and it worked fine previously up until this incident.

    Tried holding F8 to get Safe mode up, tried to get it to boot from a CD by putting one in the drive, that reminded me that i had to change the boot order in the BIOS, cant access the Bios, tried holding DEL to get there but it just takes me to my Restart screen, that put the thought that it could be more than a HDD failure

    Is this as simple as it seems, a basic HD failure? So i can Tak a look on scan and get another Laptop HDD that fits in (a bigger one too ) or has anyone had any past experience with this happening, and found out it took a piece of the mobo and a processor out with it

    Help much Appreciated
    Under Development...

  2. #2
    Drop it like it's hot Howard's Avatar
    Join Date
    Jul 2003
    Surrey, South East
    42 times in 39 posts
    • Howard's system
      • Motherboard:
      • Asus P5B
      • CPU:
      • Core2Duo E6420 2.13GHz
      • Memory:
      • 2x1gb OCZ DDR2 6400
      • Storage:
      • 250GB & 500GB Seagate
      • Graphics card(s):
      • Inno3d iChill 7900GS
      • PSU:
      • Antec SmartPower 500W
      • Case:
      • Coolermaster Elite 330
      • Monitor(s):
      • 2x AG Neovo F419
      • Internet:
      • Virgin Media 20mbit
    The HDD is knackered. Stick a new one in, and download the drivers for the laptop
    Home cinema: Toshiba 42XV555DB Full HD LCD | Onkyo TX-SR705 | NAD C352 | Monitor Audio Bronze B2 | Monitor Audio Bronze C | Monitor Audio Bronze BFX | Yamaha NSC120 | BK Monolith sub | Toshiba HD-EP35 HD-DVD | Samsung BD-P1400 BluRay Player | Pioneer DV-575 | Squeezebox3 | Virgin Media V+ Box
    PC: Asus P5B | Core2duo 2.13GHz | 2GB DDR2 PC6400 | Inno3d iChill 7900GS | Auzentech X-Plosion 7.1 | 250GB | 500GB | NEC DVDRW | Dual AG Neovo 19"
    HTPC: | Core2Duo E6420 2.13GHz | 2GB DDR2 | 250GBx2 | Radeon X1300 | Terratec Aureon 7.1 | Windows MCE 2005
    Laptop: 1.5GHz Centrino | 512MB | 60GB | 15" Wide TFT | Wifi | DVDRW

  3. #3
    Join Date
    Dec 2004
    10 times in 10 posts
    You may be able to get to the bios screen like on my old toshiba by pressing "Esc" key at boot up, will give an error then press "F1" to get to the bios screens you can then change the boot order from there. You can force it to boot from the CD by pressing the "c" on the keyboard at boot up I think, or "F10" or "F12" not sure which one now lets you pick a boot device. I think it would only be your Disk Drive at fault unless you are very unlucky.. Check maximum size supported on the disk drive, I upgraded my tosh to 40GB IDE drive no problem.

    Hope this may help you.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts