Results 1 to 9 of 9

Thread: SATA RAID1 on XP x64 - can't do it!

  1. #1
    disMember M0nkeyb0Y's Avatar
    Join Date
    Apr 2005
    Location
    Kent
    Posts
    1,046
    Thanks
    274
    Thanked
    61 times in 33 posts
    • M0nkeyb0Y's system
      • Motherboard:
      • DFI DK X58 T3 eH6
      • CPU:
      • Intel Core i7 930
      • Memory:
      • Corsair 6GB (3x2GB) DDR3 1600
      • Storage:
      • Boot: Intel SSD (80gb); + >3Tb
      • Graphics card(s):
      • ati 5870
      • PSU:
      • Corsair 750w modular
      • Case:
      • see thread in my sig
      • Operating System:
      • Windows 7 Professional
      • Monitor(s):
      • NEC EA 231wmi
      • Internet:
      • 16MB/s

    SATA RAID1 on XP x64 - can't do it!

    Howdy!

    I've just installed a couple of SATA Maxtor 7200.9 250Gb disks; Disk Manager picks them up fine, and I've initialised them; but I cannot 'mirror' them - the option simply isn't there (just 'simple', spanned, and 'stripped' - mirrored and RAID5 aren't showing).

    Am I doing something daftly wrong?!

    Please help.
    MB

  2. #2
    YUKIKAZE arthurleung's Avatar
    Join Date
    Feb 2005
    Location
    Aberdeen
    Posts
    3,280
    Thanks
    8
    Thanked
    88 times in 83 posts
    • arthurleung's system
      • Motherboard:
      • Asus P5E (Rampage Formula 0902)
      • CPU:
      • Intel Core2Quad Q9550 3.6Ghz 1.2V
      • Memory:
      • A-Data DDR2-800 2x2GB CL4
      • Storage:
      • 4x1TB WD1000FYPS @ RAID5 3Ware 9500S-8 / 3x 1TB Samsung Ecogreen F2
      • Graphics card(s):
      • GeCube HD4870 512MB
      • PSU:
      • Corsair VX450
      • Case:
      • Antec P180
      • Operating System:
      • Windows Server 2008 Standard
      • Monitor(s):
      • Dell Ultrasharp 2709W + 2001FP
      • Internet:
      • Be*Unlimited 20Mbps
    RAID0 and RAID5 is only available on Windows 2000/2003 server.

    Although, you can do some hack to the disk manager
    http://www.tomshardware.com/2004/11/...raid_5_happen/

    Not sure if it works on XP64 though.

    TBH Windows RAID5 is not terribly fast. Give it a try, if you like it, keep it, if you don't like it, drop back to RAID1 (I assume you have 4 drives?)
    Last edited by arthurleung; 05-03-2007 at 01:12 AM.
    Workstation 1: Intel i7 950 @ 3.8Ghz / X58 / 12GB DDR3-1600 / HD4870 512MB / Antec P180
    Workstation 2: Intel C2Q Q9550 @ 3.6Ghz / X38 / 4GB DDR2-800 / 8400GS 512MB / Open Air
    Workstation 3: Intel Xeon X3350 @ 3.2Ghz / P35 / 4GB DDR2-800 / HD4770 512MB / Shuttle SP35P2
    HTPC: AMD Athlon X4 620 @ 2.6Ghz / 780G / 4GB DDR2-1000 / Antec Mini P180 White
    Mobile Workstation: Intel C2D T8300 @ 2.4Ghz / GM965 / 3GB DDR2-667 / DELL Inspiron 1525 / 6+6+9 Cell Battery

    Display (Monitor): DELL Ultrasharp 2709W + DELL Ultrasharp 2001FP
    Display (Projector): Epson TW-3500 1080p
    Speakers: Creative Megaworks THX550 5.1
    Headphones: Etymotic hf2 / Ultimate Ears Triple.fi 10 Pro

    Storage: 8x2TB Hitachi @ DELL PERC 6/i RAID6 / 13TB Non-RAID Across 12 HDDs
    Consoles: PS3 Slim 120GB / Xbox 360 Arcade 20GB / PS2

  3. #3
    disMember M0nkeyb0Y's Avatar
    Join Date
    Apr 2005
    Location
    Kent
    Posts
    1,046
    Thanks
    274
    Thanked
    61 times in 33 posts
    • M0nkeyb0Y's system
      • Motherboard:
      • DFI DK X58 T3 eH6
      • CPU:
      • Intel Core i7 930
      • Memory:
      • Corsair 6GB (3x2GB) DDR3 1600
      • Storage:
      • Boot: Intel SSD (80gb); + >3Tb
      • Graphics card(s):
      • ati 5870
      • PSU:
      • Corsair 750w modular
      • Case:
      • see thread in my sig
      • Operating System:
      • Windows 7 Professional
      • Monitor(s):
      • NEC EA 231wmi
      • Internet:
      • 16MB/s
    Thanks for the reply
    I'm not sure I made myself clear in my original thread (either that or I'm being a total 'noob' and misunderstood your reply): I want RAID1 (mirrored), but am unable to bring up this option. Disks were initialised as dynamic - but the option to mirror them isn't there - and I specifically bought them for RAID1.

  4. #4
    disMember M0nkeyb0Y's Avatar
    Join Date
    Apr 2005
    Location
    Kent
    Posts
    1,046
    Thanks
    274
    Thanked
    61 times in 33 posts
    • M0nkeyb0Y's system
      • Motherboard:
      • DFI DK X58 T3 eH6
      • CPU:
      • Intel Core i7 930
      • Memory:
      • Corsair 6GB (3x2GB) DDR3 1600
      • Storage:
      • Boot: Intel SSD (80gb); + >3Tb
      • Graphics card(s):
      • ati 5870
      • PSU:
      • Corsair 750w modular
      • Case:
      • see thread in my sig
      • Operating System:
      • Windows 7 Professional
      • Monitor(s):
      • NEC EA 231wmi
      • Internet:
      • 16MB/s
    PLEASE GUYS! this is driving me nuts - surely someone outthere has RAID1 on x64 or even XP - and can maybe suggest where I'm going wrong?

  5. #5
    ***** Lurker
    Join Date
    Aug 2005
    Posts
    722
    Thanks
    2
    Thanked
    15 times in 15 posts
    • d3fiant's system
      • Motherboard:
      • GB X58A-UDR3 FB11
      • CPU:
      • Core i7 950
      • Memory:
      • Corsair 12GB DDR3 1600
      • Storage:
      • 2x 120GB OCZ Agility SSD + 500GB SP F3
      • Graphics card(s):
      • GB Windforce GTX670 2GB
      • PSU:
      • 850W Akasa
      • Case:
      • Fractal R3
      • Operating System:
      • Windows 7 x64 HP Retail
      • Monitor(s):
      • 24" 1920x1080 Iiyama LED
      • Internet:
      • 60MB VM
    surely it would be better to do this on the onboard RAID controller rather than in the OS or am I missing the point

  6. #6
    disMember M0nkeyb0Y's Avatar
    Join Date
    Apr 2005
    Location
    Kent
    Posts
    1,046
    Thanks
    274
    Thanked
    61 times in 33 posts
    • M0nkeyb0Y's system
      • Motherboard:
      • DFI DK X58 T3 eH6
      • CPU:
      • Intel Core i7 930
      • Memory:
      • Corsair 6GB (3x2GB) DDR3 1600
      • Storage:
      • Boot: Intel SSD (80gb); + >3Tb
      • Graphics card(s):
      • ati 5870
      • PSU:
      • Corsair 750w modular
      • Case:
      • see thread in my sig
      • Operating System:
      • Windows 7 Professional
      • Monitor(s):
      • NEC EA 231wmi
      • Internet:
      • 16MB/s
    Quote Originally Posted by d3fiant View Post
    surely it would be better to do this on the onboard RAID controller rather than in the OS or am I missing the point
    No you're not - would this be better? I naively assumed Disk Manager would be the easiest and best way to do it .

    I did try to access my onboard RAID controller on start up (ctrl+s), but couldn't get in... will try again when I get home.

  7. #7
    ***** Lurker
    Join Date
    Aug 2005
    Posts
    722
    Thanks
    2
    Thanked
    15 times in 15 posts
    • d3fiant's system
      • Motherboard:
      • GB X58A-UDR3 FB11
      • CPU:
      • Core i7 950
      • Memory:
      • Corsair 12GB DDR3 1600
      • Storage:
      • 2x 120GB OCZ Agility SSD + 500GB SP F3
      • Graphics card(s):
      • GB Windforce GTX670 2GB
      • PSU:
      • 850W Akasa
      • Case:
      • Fractal R3
      • Operating System:
      • Windows 7 x64 HP Retail
      • Monitor(s):
      • 24" 1920x1080 Iiyama LED
      • Internet:
      • 60MB VM
    I would do it using the onboard controller, however I have only done this from a clean build. If you want to introduce an identicle hard drive and create a RAID1 set from the exisitng build you may need to take extra care but Im sure it can be done. You may even be able to do this from within the OS by installing the apprpriate software to access the onboard controller, for example with your Nvidia based mobo you should try the Nvidia Mediashield Storage software, it can create the raid array for you but make sure you read the extensive instruction manual to better understand the risks to ur data while setting it up
    Last edited by d3fiant; 05-03-2007 at 05:51 PM.

  8. #8
    disMember M0nkeyb0Y's Avatar
    Join Date
    Apr 2005
    Location
    Kent
    Posts
    1,046
    Thanks
    274
    Thanked
    61 times in 33 posts
    • M0nkeyb0Y's system
      • Motherboard:
      • DFI DK X58 T3 eH6
      • CPU:
      • Intel Core i7 930
      • Memory:
      • Corsair 6GB (3x2GB) DDR3 1600
      • Storage:
      • Boot: Intel SSD (80gb); + >3Tb
      • Graphics card(s):
      • ati 5870
      • PSU:
      • Corsair 750w modular
      • Case:
      • see thread in my sig
      • Operating System:
      • Windows 7 Professional
      • Monitor(s):
      • NEC EA 231wmi
      • Internet:
      • 16MB/s
    Thanks for the reply,

    These are two identical drives, I'm adding to my existing setup for extra storage, to make one mirrored volume - I'm guessing this should be safe enough?

  9. #9
    YUKIKAZE arthurleung's Avatar
    Join Date
    Feb 2005
    Location
    Aberdeen
    Posts
    3,280
    Thanks
    8
    Thanked
    88 times in 83 posts
    • arthurleung's system
      • Motherboard:
      • Asus P5E (Rampage Formula 0902)
      • CPU:
      • Intel Core2Quad Q9550 3.6Ghz 1.2V
      • Memory:
      • A-Data DDR2-800 2x2GB CL4
      • Storage:
      • 4x1TB WD1000FYPS @ RAID5 3Ware 9500S-8 / 3x 1TB Samsung Ecogreen F2
      • Graphics card(s):
      • GeCube HD4870 512MB
      • PSU:
      • Corsair VX450
      • Case:
      • Antec P180
      • Operating System:
      • Windows Server 2008 Standard
      • Monitor(s):
      • Dell Ultrasharp 2709W + 2001FP
      • Internet:
      • Be*Unlimited 20Mbps
    Really sorry, I meant RAID1 and RAID5 not RAID0 and RAID5...

    Still, if you want to run it on windows xp you'll need to hack the disk manager.

    Personally I feel that running windows' software raid is a lot safer than using the nvidia raid if you ever change motherboard.
    Workstation 1: Intel i7 950 @ 3.8Ghz / X58 / 12GB DDR3-1600 / HD4870 512MB / Antec P180
    Workstation 2: Intel C2Q Q9550 @ 3.6Ghz / X38 / 4GB DDR2-800 / 8400GS 512MB / Open Air
    Workstation 3: Intel Xeon X3350 @ 3.2Ghz / P35 / 4GB DDR2-800 / HD4770 512MB / Shuttle SP35P2
    HTPC: AMD Athlon X4 620 @ 2.6Ghz / 780G / 4GB DDR2-1000 / Antec Mini P180 White
    Mobile Workstation: Intel C2D T8300 @ 2.4Ghz / GM965 / 3GB DDR2-667 / DELL Inspiron 1525 / 6+6+9 Cell Battery

    Display (Monitor): DELL Ultrasharp 2709W + DELL Ultrasharp 2001FP
    Display (Projector): Epson TW-3500 1080p
    Speakers: Creative Megaworks THX550 5.1
    Headphones: Etymotic hf2 / Ultimate Ears Triple.fi 10 Pro

    Storage: 8x2TB Hitachi @ DELL PERC 6/i RAID6 / 13TB Non-RAID Across 12 HDDs
    Consoles: PS3 Slim 120GB / Xbox 360 Arcade 20GB / PS2

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 63
    Last Post: 14-11-2011, 09:17 AM
  2. IDE Optical drives on a SATA controller using an IDE to SATA converter
    By Skinleech in forum PC Hardware and Components
    Replies: 5
    Last Post: 11-07-2007, 11:56 PM
  3. SATA and SATA II
    By stephent3 in forum PC Hardware and Components
    Replies: 19
    Last Post: 17-10-2006, 10:05 AM
  4. WD Raptor SATA power connector
    By Taz in forum PC Hardware and Components
    Replies: 1
    Last Post: 08-05-2005, 11:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •