Results 1 to 11 of 11

Thread: Error running old exe files in win10

  1. #1
    RIP Peterb ik9000's Avatar
    Join Date
    Nov 2009
    Posts
    7,475
    Thanks
    1,755
    Thanked
    1,323 times in 988 posts
    • ik9000's system
      • Motherboard:
      • Asus P7H55-M/USB3
      • CPU:
      • i7-870, Prolimatech Megahalems, 2x Akasa Apache 120mm
      • Memory:
      • 4x4GB Corsair Vengeance 2133 11-11-11-27
      • Storage:
      • 2x256GB Samsung 840-Pro, 1TB Seagate 7200.12, 1TB Seagate ES.2
      • Graphics card(s):
      • Gigabyte GTX 460 1GB SuperOverClocked
      • PSU:
      • NZXT Hale 90 750w
      • Case:
      • BitFenix Survivor + Bitfenix spectre LED fans, LG BluRay R/W optical drive
      • Operating System:
      • Windows 7 Professional
      • Monitor(s):
      • Dell U2414h, U2311h 1920x1080
      • Internet:
      • 200Mb/s Fibre and 4G wifi

    Error running old exe files in win10

    Anyone got any idea why an ISO or rather the series of exe files it contains would run fine in win7 but not in win10? No DRM SFAIK - i don't think it's a secdrv.sys issue or such like. (the iso wouldn't work in win7 either, as it runs fine with that deactivated)

    Manually trying to run various exe files (whether from within or extracted from the ISO) crashes with "this file or directory is corrupted and unreadable". Only they're not corrupted. You can stick them on win7 and off they go. The comp has .net3.5 and 4.8 installed and I've ticked the "legacy" option in programs and features -> windows features. I've changed compatibility settings for the files. Clearly there's something it wants to run but I'm stumped to know what's missing.

    Any pointers on what I could try?

  2. #2
    Senior Member
    Join Date
    Feb 2008
    Posts
    919
    Thanks
    4
    Thanked
    157 times in 145 posts
    • smargh's system
      • Motherboard:
      • Gigabyte GA-EP45-UD3P
      • CPU:
      • Xeon E5450 with 775-to-771 Mod
      • Memory:
      • 16GB Crucial
      • Storage:
      • Intel X25-M G2 80GB/Adaptec 3405 4x 2TB Ultrastar RAID1 / 1x 6TB Hitachi He6 / Dying 2TB Samsung
      • Graphics card(s):
      • GTX 750 Ti
      • PSU:
      • Seasonic X-560
      • Case:
      • Lian-Li PC-A71
      • Operating System:
      • Windows 7 Ultimate 64bit
      • Monitor(s):
      • BenQ G2400WD
      • Internet:
      • Really Crap ADSL2 <3Mbit

    Re: Error running old exe files in win10

    Maybe run the Win10 memory diagnostic?

    Or if the files are 32bit, maybe it could be a wow64 issue. Try doing a chkdsk.

    Might be a job for Process Monitor to see what's happening in the background when the error appears.

  3. #3
    Senior Member AGTDenton's Avatar
    Join Date
    Jun 2009
    Location
    Bracknell
    Posts
    2,169
    Thanks
    676
    Thanked
    548 times in 380 posts
    • AGTDenton's system
      • Motherboard:
      • ASUS P6T7 WS Supercomputer
      • CPU:
      • Intel Core i7 980
      • Memory:
      • 24GB Corsair Dominator GT
      • Storage:
      • Samsung 860 Pro + HDDs
      • Graphics card(s):
      • Asus 1030
      • PSU:
      • Seasonic X-850W
      • Case:
      • Fractal Design R3
      • Operating System:
      • 10 Pro x64
      • Internet:
      • 70MB using BT line

    Re: Error running old exe files in win10

    It's possible Windows defender or your AV is seeing a false positive.
    Windows defender is certainly stricter in 10 but doesn't always report it has blocked or found something.

    Is it network related over TLS or SSL. There's been quite a change in that department with Windows 10
    Have you tried more than one Windows 10 machine?

    I'm guessing it's not public software by the fact you've not mentioned its name? not something we'd be able to try?
    Can we have an idea as to what the software does.
    Last edited by AGTDenton; 09-01-2022 at 02:46 AM.

  4. #4
    blueball
    Guest

    Re: Error running old exe files in win10

    Are both the Win 7 and Win 10 64bit?

    If the exe's are 8bit they will run in a 32bit platform but not a 64bit platform - I lost access to a very expensive CAD program due to being unable to install it on a 64bit platform as, though the program itself was 16bit, the installation exe was 8bit so wouldn't run.

  5. #5
    RIP Peterb ik9000's Avatar
    Join Date
    Nov 2009
    Posts
    7,475
    Thanks
    1,755
    Thanked
    1,323 times in 988 posts
    • ik9000's system
      • Motherboard:
      • Asus P7H55-M/USB3
      • CPU:
      • i7-870, Prolimatech Megahalems, 2x Akasa Apache 120mm
      • Memory:
      • 4x4GB Corsair Vengeance 2133 11-11-11-27
      • Storage:
      • 2x256GB Samsung 840-Pro, 1TB Seagate 7200.12, 1TB Seagate ES.2
      • Graphics card(s):
      • Gigabyte GTX 460 1GB SuperOverClocked
      • PSU:
      • NZXT Hale 90 750w
      • Case:
      • BitFenix Survivor + Bitfenix spectre LED fans, LG BluRay R/W optical drive
      • Operating System:
      • Windows 7 Professional
      • Monitor(s):
      • Dell U2414h, U2311h 1920x1080
      • Internet:
      • 200Mb/s Fibre and 4G wifi

    Re: Error running old exe files in win10

    The original is probably, almost certainly, 32 bit given its age. Everything runs in 64 bit win 7 just fine on several machines, including one where the hardware runs the thing just fine on win 7 but not with win 10. I've tried it on 3 different win 10 machines. 1909, 2004, 21h1. All give the same refusal/error message.

    It's not AV. That auto green lists it and there are no log entries against it. It appears to be Windows grumbling. I tried installing wincdemu which I use in win 7 just to check it's not a quirk of the native iso mounting in win 10. It makes no difference.

    It's like win 10 just doesn't like the exe.
    Last edited by ik9000; 10-01-2022 at 12:19 PM.

  6. #6
    RIP Peterb ik9000's Avatar
    Join Date
    Nov 2009
    Posts
    7,475
    Thanks
    1,755
    Thanked
    1,323 times in 988 posts
    • ik9000's system
      • Motherboard:
      • Asus P7H55-M/USB3
      • CPU:
      • i7-870, Prolimatech Megahalems, 2x Akasa Apache 120mm
      • Memory:
      • 4x4GB Corsair Vengeance 2133 11-11-11-27
      • Storage:
      • 2x256GB Samsung 840-Pro, 1TB Seagate 7200.12, 1TB Seagate ES.2
      • Graphics card(s):
      • Gigabyte GTX 460 1GB SuperOverClocked
      • PSU:
      • NZXT Hale 90 750w
      • Case:
      • BitFenix Survivor + Bitfenix spectre LED fans, LG BluRay R/W optical drive
      • Operating System:
      • Windows 7 Professional
      • Monitor(s):
      • Dell U2414h, U2311h 1920x1080
      • Internet:
      • 200Mb/s Fibre and 4G wifi

    Re: Error running old exe files in win10

    Quote Originally Posted by AGTDenton View Post
    It's possible Windows defender or your AV is seeing a false positive.
    Windows defender is certainly stricter in 10 but doesn't always report it has blocked or found something.

    Is it network related over TLS or SSL. There's been quite a change in that department with Windows 10
    Have you tried more than one Windows 10 machine?

    I'm guessing it's not public software by the fact you've not mentioned its name? not something we'd be able to try?
    Can we have an idea as to what the software does.
    I don't think it's network related. I can't even get it to install to even get to that stage. It's an old file, never needed online access or activation or such like. Not even a CD key it's that old.

  7. #7
    RIP Peterb ik9000's Avatar
    Join Date
    Nov 2009
    Posts
    7,475
    Thanks
    1,755
    Thanked
    1,323 times in 988 posts
    • ik9000's system
      • Motherboard:
      • Asus P7H55-M/USB3
      • CPU:
      • i7-870, Prolimatech Megahalems, 2x Akasa Apache 120mm
      • Memory:
      • 4x4GB Corsair Vengeance 2133 11-11-11-27
      • Storage:
      • 2x256GB Samsung 840-Pro, 1TB Seagate 7200.12, 1TB Seagate ES.2
      • Graphics card(s):
      • Gigabyte GTX 460 1GB SuperOverClocked
      • PSU:
      • NZXT Hale 90 750w
      • Case:
      • BitFenix Survivor + Bitfenix spectre LED fans, LG BluRay R/W optical drive
      • Operating System:
      • Windows 7 Professional
      • Monitor(s):
      • Dell U2414h, U2311h 1920x1080
      • Internet:
      • 200Mb/s Fibre and 4G wifi

    Re: Error running old exe files in win10

    interestingly I've dug through the loft and found the original CD and gone to a machine with a DVD drive. This does run on win10. I'm not sure why the iso that works on win7 won't in win10. If it were some primitive securom etc wouldn't win10 reject the CD altogether? Anyway clearly something is borked in the iso that plays with 7 but not 10. I'll see if I can remake the iso in a more robust format.

  8. #8
    RIP Peterb ik9000's Avatar
    Join Date
    Nov 2009
    Posts
    7,475
    Thanks
    1,755
    Thanked
    1,323 times in 988 posts
    • ik9000's system
      • Motherboard:
      • Asus P7H55-M/USB3
      • CPU:
      • i7-870, Prolimatech Megahalems, 2x Akasa Apache 120mm
      • Memory:
      • 4x4GB Corsair Vengeance 2133 11-11-11-27
      • Storage:
      • 2x256GB Samsung 840-Pro, 1TB Seagate 7200.12, 1TB Seagate ES.2
      • Graphics card(s):
      • Gigabyte GTX 460 1GB SuperOverClocked
      • PSU:
      • NZXT Hale 90 750w
      • Case:
      • BitFenix Survivor + Bitfenix spectre LED fans, LG BluRay R/W optical drive
      • Operating System:
      • Windows 7 Professional
      • Monitor(s):
      • Dell U2414h, U2311h 1920x1080
      • Internet:
      • 200Mb/s Fibre and 4G wifi

    Re: Error running old exe files in win10

    New iso made and so far so good - now to test on the other machines. It no longer seems happy to run without the disc after install (which it always did on everything from win98se upwards) but mounting the new iso seems to bypass that so that's good enough for me. Clearly there is something win10 is happy to skip as the new iso made using win10 is smaller than the old win7 made iso.

    What a faff.

  9. Received thanks from:

    AGTDenton (11-01-2022)

  10. #9
    Senior Member AGTDenton's Avatar
    Join Date
    Jun 2009
    Location
    Bracknell
    Posts
    2,169
    Thanks
    676
    Thanked
    548 times in 380 posts
    • AGTDenton's system
      • Motherboard:
      • ASUS P6T7 WS Supercomputer
      • CPU:
      • Intel Core i7 980
      • Memory:
      • 24GB Corsair Dominator GT
      • Storage:
      • Samsung 860 Pro + HDDs
      • Graphics card(s):
      • Asus 1030
      • PSU:
      • Seasonic X-850W
      • Case:
      • Fractal Design R3
      • Operating System:
      • 10 Pro x64
      • Internet:
      • 70MB using BT line

    Re: Error running old exe files in win10

    Glad to hear you managed to sort it, thank goodness for finding the original CD. That's clearly saved a long headache.

    What software did you use to make the ISO originally vs now? If you can remember the original of course

  11. #10
    RIP Peterb ik9000's Avatar
    Join Date
    Nov 2009
    Posts
    7,475
    Thanks
    1,755
    Thanked
    1,323 times in 988 posts
    • ik9000's system
      • Motherboard:
      • Asus P7H55-M/USB3
      • CPU:
      • i7-870, Prolimatech Megahalems, 2x Akasa Apache 120mm
      • Memory:
      • 4x4GB Corsair Vengeance 2133 11-11-11-27
      • Storage:
      • 2x256GB Samsung 840-Pro, 1TB Seagate 7200.12, 1TB Seagate ES.2
      • Graphics card(s):
      • Gigabyte GTX 460 1GB SuperOverClocked
      • PSU:
      • NZXT Hale 90 750w
      • Case:
      • BitFenix Survivor + Bitfenix spectre LED fans, LG BluRay R/W optical drive
      • Operating System:
      • Windows 7 Professional
      • Monitor(s):
      • Dell U2414h, U2311h 1920x1080
      • Internet:
      • 200Mb/s Fibre and 4G wifi

    Re: Error running old exe files in win10

    Quote Originally Posted by AGTDenton View Post
    Glad to hear you managed to sort it, thank goodness for finding the original CD. That's clearly saved a long headache.

    What software did you use to make the ISO originally vs now? If you can remember the original of course
    wincdemu this time. I think it was that last time (albeit older version), or possibly cdburnerxp. It was a while ago now. It's relatively simple when there's no safedisc/securom to worry about. Otherwise it needs another level of software.

  12. #11
    Senior Member AGTDenton's Avatar
    Join Date
    Jun 2009
    Location
    Bracknell
    Posts
    2,169
    Thanks
    676
    Thanked
    548 times in 380 posts
    • AGTDenton's system
      • Motherboard:
      • ASUS P6T7 WS Supercomputer
      • CPU:
      • Intel Core i7 980
      • Memory:
      • 24GB Corsair Dominator GT
      • Storage:
      • Samsung 860 Pro + HDDs
      • Graphics card(s):
      • Asus 1030
      • PSU:
      • Seasonic X-850W
      • Case:
      • Fractal Design R3
      • Operating System:
      • 10 Pro x64
      • Internet:
      • 70MB using BT line

    Re: Error running old exe files in win10

    I used to use ImgBurn religiously but started having issues with it (not to mention they added adware to the latest installer) and moved to Active@ ISO Burner

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •