Results 1 to 6 of 6

Thread: Corsair Gaming K70 RGB USB Issue...

  1. #1
    Senior Member
    Join Date
    Feb 2011
    Location
    Lancashire
    Posts
    727
    Thanks
    10
    Thanked
    20 times in 19 posts
    • PowerPie5000's system
      • Motherboard:
      • ASUS Z9PA-U8
      • CPU:
      • Intel Xeon E5-1660 V2
      • Memory:
      • 32GB Kingston DDR3 1600
      • Storage:
      • 250GB Crucial MX200 SSD + 2TB Toshiba SATA HDD
      • Graphics card(s):
      • 8GB MSI Radeon RX 480 Armor OC
      • PSU:
      • Super Flower Golden Green HX 550W (80+ Gold)
      • Case:
      • AeroCool Dead Silence 230
      • Operating System:
      • Windows 10 64-bit
      • Monitor(s):
      • 23" HP 2310i (1080p)
      • Internet:
      • 38Mb TalkTalk Fibre

    Corsair Gaming K70 RGB USB Issue...

    I've noticed a bug or fault when I plug both cables in to the USB 2.0 ports on my Asrock Z97 Extreme4 board... I get an error in the device manager that says "Unknown USB Device (Device Descriptor Request Failed)". I'm also running Windows 10 64-bit and the keyboard has the latest CUE software and firmware installed. I don't get the error if I use a single cable in one of the USB 3.0 ports, but if I plug both in to the USB 3.0 ports then I get the error again.

    It happens whenever I plug in the extra power cable in to one of the native Intel USB 2.0 or 3.0 ports. It doesn't happen if I use the third party ASMedia USB 3.0 ports (which I usually avoid using anyway). Is there a fix for this? My motherboard has the latest BIOS and all my device drivers are up to date.


    [IMG][/IMG]

  2. #2
    Senior Member
    Join Date
    Feb 2011
    Location
    Lancashire
    Posts
    727
    Thanks
    10
    Thanked
    20 times in 19 posts
    • PowerPie5000's system
      • Motherboard:
      • ASUS Z9PA-U8
      • CPU:
      • Intel Xeon E5-1660 V2
      • Memory:
      • 32GB Kingston DDR3 1600
      • Storage:
      • 250GB Crucial MX200 SSD + 2TB Toshiba SATA HDD
      • Graphics card(s):
      • 8GB MSI Radeon RX 480 Armor OC
      • PSU:
      • Super Flower Golden Green HX 550W (80+ Gold)
      • Case:
      • AeroCool Dead Silence 230
      • Operating System:
      • Windows 10 64-bit
      • Monitor(s):
      • 23" HP 2310i (1080p)
      • Internet:
      • 38Mb TalkTalk Fibre

    Re: Corsair Gaming K70 RGB USB Issue...

    Just a follow up... Is it normal for the keyboard HID to be listed 3 times in device manager? I tried removing them but all 3 come back instead of just the one. I'm also getting an intermittent bug where the CUE software can't detect the keyboard from a cold boot so I then have to unplug it and plug it back in again. It doesn't happen all the time though.

    I'm guessing it must be down to slightly buggy software or firmware instead of an actual hardware fault? I few people have had these issues after a bit of googling.

  3. #3
    Corsair Rep
    Join Date
    May 2013
    Location
    Corsair HQ
    Posts
    488
    Thanks
    2
    Thanked
    69 times in 55 posts

    Re: Corsair Gaming K70 RGB USB Issue...

    Hey Powerpie,
    If you're using USB3.0 port, you really don't need to plug in both connectors, one connector is fine, the one with the KB icon. http://forum.corsair.com/v3/showthread.php?t=132322

    As for the KB not being detected coming from cold boot, try to enable ErP in BIOS and then change your sleep mode to S3 (which will allow any key press to wake the system).

  4. #4
    Senior Member
    Join Date
    Feb 2011
    Location
    Lancashire
    Posts
    727
    Thanks
    10
    Thanked
    20 times in 19 posts
    • PowerPie5000's system
      • Motherboard:
      • ASUS Z9PA-U8
      • CPU:
      • Intel Xeon E5-1660 V2
      • Memory:
      • 32GB Kingston DDR3 1600
      • Storage:
      • 250GB Crucial MX200 SSD + 2TB Toshiba SATA HDD
      • Graphics card(s):
      • 8GB MSI Radeon RX 480 Armor OC
      • PSU:
      • Super Flower Golden Green HX 550W (80+ Gold)
      • Case:
      • AeroCool Dead Silence 230
      • Operating System:
      • Windows 10 64-bit
      • Monitor(s):
      • 23" HP 2310i (1080p)
      • Internet:
      • 38Mb TalkTalk Fibre

    Re: Corsair Gaming K70 RGB USB Issue...

    It seems to be running fine from one USB 3.0 port and it also had a new firmware update earlier today (2.05). It seems to be perfect so far... I'm not sure what changed in the latest firmware?. It's still listed as 3 keyboard HID in the device manager though when my other keyboard show it once. Is this normal?

  5. #5
    Registered+
    Join Date
    Apr 2013
    Posts
    25
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Corsair Gaming K70 RGB USB Issue...

    It's not abnormal, I cannot for the life of me remember which keyboard it was now!..
    But I've had '2' keyboard HID devices show up before, 1 was the actual keyboard, the other was the number pad - for since reason windows thought they were separate haha

    Not sure what the 3rd would be though

  6. #6
    Corsair Rep
    Join Date
    May 2013
    Location
    Corsair HQ
    Posts
    488
    Thanks
    2
    Thanked
    69 times in 55 posts

    Re: Corsair Gaming K70 RGB USB Issue...

    3 HID devices is normal, that's to enable macros and handle other tasks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •