Results 1 to 6 of 6

Thread: RMA'd PSU to Scan - let down, let down again, and again

  1. #1
    Senior Member
    Join Date
    Jun 2006
    Location
    London, UK
    Posts
    710
    Thanks
    33
    Thanked
    5 times in 5 posts

    RMA'd PSU to Scan - let down, let down again, and again

    Hi

    RMA and Invoice number will be sent to Lee, Wesley, whoever needs it or requests it - saves you deleting it from this post guys. I've taken the names out, will pass them to you if you want them.

    Wednesday 13th - I used your online return query form as I needed to return a faulty Xclio 750W PSU to you. I gave a full description of its faults on this page, in summary:

    the PSU continues to buzz even after I have completely shutdown my PC (and this buzz never stops);
    it's advertised as quiet but not remotely - it's the loudest thing in my system;
    it's got louder in just the 5 or 6 times I've used my PC with it installed;
    it is completely missing the 4pin Intel CPU power connector it was advertised with (and also mentioned in the manual).

    Friday 15th - I had heard nothing so I called to chase it and arranged an RMA. I was promised by .... that it would be properly tested and when found to be faulty I would receive a refund in 3-5 working days.

    Tuesday 19th - You received it and rejected my RMA with the report "scratches on the PSU". It is very obvious I returned it as faulty, not as unwanted to be restocked (I put a list of the faults in the parcel with the PSU).

    Wednesday 20th - 9.30am I spoke to ..... on your returns team, who was as confused with the report as me and said he would get it actually tested and call me back. He didn't. I called him at 5.20pm, he said he hadn't had time to speak to anyone and would chase it Thursday first thing and call me.

    Thursday 21st - No call again so I have to ring your 0870 number and hence pay you for the priviledge, again, of chasing this. Same guy in returns team apologised and promised me it will be tested today and I will be called.

    Friday 22nd - Nothing. Am I going to have to call you at my expense yet again? That's why I'm posting.

    The PSU is clearly faulty. You have had plenty of business from me recently. I still want to get two monitors, two 250GB hard drives and a diNovo desktop set but at the moment all the hundreds of pounds I have spent with you is a useless PC sat on my desk until this PSU gets sorted.

    Can someone please, please, just do as promised and get it done? I'm sympathetic if people are overworked, believe me (and as such I've left the individual's names out of this post), but that doesn't make this acceptable. I've never experienced anything this bad with any retailer.

    Thank you

    DM
    Last edited by dancingmatt; 22-09-2006 at 02:42 PM.

  2. #2
    Registered User
    Join Date
    Sep 2003
    Location
    Bolton
    Posts
    1,478
    Thanks
    168
    Thanked
    90 times in 74 posts
    Please accept my apologies for the problems you have encountered, I have tested this with a Technician and can confirm the following, The missing 4 pin adapter detaches from the 24 pin plug giving you a 20 pin connector and 4 pin for cpu, so no problem there.

    The buzzing is present exactly as you stated, therefore the RMA has been updated and a replacement will be shipped as promised.

    I have spoken to the call centre representative whom assisted you and to be honest he did do all he could, he promised a callback when he had some news and unfortunately upto now did not have any news to pass on as the Technical team are working through a backlog and had not managed to get to this item until my intervention.

    Hope this all helps.

    Wesley

  3. #3
    Senior Member
    Join Date
    Jun 2006
    Location
    London, UK
    Posts
    710
    Thanks
    33
    Thanked
    5 times in 5 posts
    That does help, Wesley, thank you.

    However, I do not want a replacement - I was promised in my original phone call when arranging the RMA that when the returned Xclio PSU was found to be faulty I would receive a full refund to my card, and this is what I want.

    You will be able to tell from my account that I have already bought and received a Seasonic S12-600W PSU from you. So you have already received my business for this and I need my card refunded.

    As I said, I sympathise that sometimes people have too much on but in turn you can understand my frustration.

    Please confirm you are actioning my refund.

    Many thanks

    DM

  4. #4
    Senior Member
    Join Date
    Jun 2006
    Location
    London, UK
    Posts
    710
    Thanks
    33
    Thanked
    5 times in 5 posts
    Oh, and the missing 4pin adaptor is the additional connector needed for the motherboard near the CPU socket, not the one which is part of the 20+4pin ATX connector. You need both the 24pin ATX and the 4pin CPU connector for an Asus P5W DH Deluxe board, and it was advertised and detailed in the manual as having:

    "PSU Cable Set: 20+4pins, 2 x PCI express & 4 pins Intel CPU power connector"

    - it's this last connector which is missing from the wires attached to the PSU.

    Anyway, this is irrelevant now. I look forward to your confirmation of the refund being actioned.

    Thanks again

    DM

  5. #5
    Registered User
    Join Date
    Sep 2003
    Location
    Bolton
    Posts
    1,478
    Thanks
    168
    Thanked
    90 times in 74 posts
    I have ammended your RMA to refund.

  6. #6
    Senior Member
    Join Date
    Jun 2006
    Location
    London, UK
    Posts
    710
    Thanks
    33
    Thanked
    5 times in 5 posts
    Thanks very much again, Wesley. Very glad that it's finally sorted and I do appreciate your help.

    DM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •