Results 1 to 12 of 12

Thread: ehshell.exe crashes associated with Vista Media Centre

  1. #1
    Asking silly questions menthel's Avatar
    Join Date
    Apr 2004
    Location
    Rainey Park...
    Posts
    5,077
    Thanks
    258
    Thanked
    97 times in 78 posts

    ehshell.exe crashes associated with Vista Media Centre

    Hi peeps, just a quick heads up about this.

    I had started to experience crashes and lost recordings on running media centre both through vista and my xbox 360 as an extender. Looking at it in Vista I found all of them to be ehshell.exe crashes.

    After some searching around the internet I found the problem!

    Apparently sometimes the files for the EPG and associated files start to get really long file names (some over 500 characters) and this causes the crashes.

    The fix is simple. Find the EPG folder (I used windows search, advanced and show all files inc hidden etc) and delete it. Then reboot MC, scan for channels and then download the EPG. This sorts it out. You will have to reschedule all of your recordings though.

    I hope that helps someone!
    Not around too often!

  2. Received thanks from:

    dangel (06-11-2007),mallett (09-11-2007),roorooroo (09-11-2007),this_is_gav (06-11-2007)

  3. #2
    Senior Member
    Join Date
    Aug 2005
    Location
    Leeds
    Posts
    267
    Thanks
    8
    Thanked
    16 times in 16 posts

    Re: ehshell.exe crashes associated with Vista Media Centre

    The other possible cause is if you're using FFDshow then it seems to trigger DEP when you quit MCE, which means an instant restart of MCE again

    EDIT: that's a lot of acronyms, isn't it!

  4. #3
    HEXUS.social member Agent's Avatar
    Join Date
    Jul 2003
    Location
    Internet
    Posts
    19,159
    Thanks
    733
    Thanked
    1,605 times in 1,044 posts

    Re: ehshell.exe crashes associated with Vista Media Centre

    Can you disable DEP per application? I know you can in XP.
    Quote Originally Posted by Saracen View Post
    And by trying to force me to like small pants, they've alienated me.

  5. #4
    Senior Member
    Join Date
    Aug 2005
    Location
    Leeds
    Posts
    267
    Thanks
    8
    Thanked
    16 times in 16 posts

    Re: ehshell.exe crashes associated with Vista Media Centre

    In a way - the two options are "on for all essential programs and services" or "on for everything except..."

    I just can't be bothered messing around with it, I switched it on and immediately (after a reset at least) ran into a couple of programs in a row that needed exceptions, so I switched it back off. Life's too short.

  6. #5
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU

    Re: ehshell.exe crashes associated with Vista Media Centre

    I get the DEP crashes a fair bit - always when it's showing a thumbnail list of my downloaded content (i.e. not recorded). It's probably dying whilst re-caching the thumbnails from the videos and it's almost certainly FFDshow causing it. Oddly, it's only been happening more recently and i've not updated FFDshow etc. Unless a windows update has caused it.. Hmm. Fortunately this doesn't happen during playback so it's 'workable'. I may play around this weekend and if i solve it i'll report back. Codecs, gah!
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


  7. #6
    Senior Member roorooroo's Avatar
    Join Date
    Oct 2006
    Location
    Cheshire cat country
    Posts
    1,266
    Thanks
    80
    Thanked
    78 times in 55 posts
    • roorooroo's system
      • Motherboard:
      • ga-z170-Gaming 3
      • CPU:
      • Skylake i7 6700k
      • Memory:
      • 16gb corsair vengeance
      • Storage:
      • 4 TB (3xHD), 3xSSD
      • Graphics card(s):
      • GTX 980ti
      • PSU:
      • tX 850w Corsair
      • Case:
      • cooler master haf92
      • Monitor(s):
      • 32" Panasonic
      • Internet:
      • "up to" 152mb

    Re: ehshell.exe crashes associated with Vista Media Centre

    Will give this a go later thanks for the tip...i've just installed my media center system so that will be of help..main problem i have had is a blank black screen when accessing my networked avi folders..i think i may have too many shared? Not sure.

    Cheers, Roo

  8. #7
    Asking silly questions menthel's Avatar
    Join Date
    Apr 2004
    Location
    Rainey Park...
    Posts
    5,077
    Thanks
    258
    Thanked
    97 times in 78 posts

    Re: ehshell.exe crashes associated with Vista Media Centre

    I have no clue what any of you are on about now!

    I certainly have no idea what DEP is!

    Not around too often!

  9. #8
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU

    Re: ehshell.exe crashes associated with Vista Media Centre

    Data Execution Prevention - Wikipedia, the free encyclopedia

    Basically some piece of code is broken - probably in a codec (probaly in FFDshow) - and windows is treating it as a potential security threat (and hence waxes the exe).
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


  10. #9
    Senior Member roorooroo's Avatar
    Join Date
    Oct 2006
    Location
    Cheshire cat country
    Posts
    1,266
    Thanks
    80
    Thanked
    78 times in 55 posts
    • roorooroo's system
      • Motherboard:
      • ga-z170-Gaming 3
      • CPU:
      • Skylake i7 6700k
      • Memory:
      • 16gb corsair vengeance
      • Storage:
      • 4 TB (3xHD), 3xSSD
      • Graphics card(s):
      • GTX 980ti
      • PSU:
      • tX 850w Corsair
      • Case:
      • cooler master haf92
      • Monitor(s):
      • 32" Panasonic
      • Internet:
      • "up to" 152mb

    Re: ehshell.exe crashes associated with Vista Media Centre

    Quote Originally Posted by menthel View Post
    I have no clue what any of you are on about now!

    I certainly have no idea what DEP is!


    lol..i had to google DEP too

  11. #10
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU

    Re: ehshell.exe crashes associated with Vista Media Centre

    You can try disabling DEP altogether just to see how things go.

    Disable DEP in Vista:

    1. Click Start
    2. Click All Programs
    3. Click Accessories
    4. Right Click on Command Prompt
    5. Left click on Run as Administrator
    6. Click the Allow button if it asks you for permission
    7. Type or copy and paste this into the command prompt window:

    bcdedit.exe /set {current} nx AlwaysOff


    8. Hit enter and you should see the confirmation: Operation Completed Successfully
    9. Reboot and DEP should be off.

    NOTE: the real problem here is a codec failing - finding and eliminating the problem properly would be a far better idea. I'll try and do this at the weekend but there's plenty of mention of DEP issues with mkv/x264/xvid codecs on t'web.

    More selectively:

    Start->Right click on Computer->Properties->Advanced System Settings
    Choose Advanced
    Choose settings for performance
    Choose Data Execution Prevention
    Add exes you want to be ignore to the list using the controls provided.
    Last edited by dangel; 09-11-2007 at 03:01 PM.
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


  12. #11
    Senior Member roorooroo's Avatar
    Join Date
    Oct 2006
    Location
    Cheshire cat country
    Posts
    1,266
    Thanks
    80
    Thanked
    78 times in 55 posts
    • roorooroo's system
      • Motherboard:
      • ga-z170-Gaming 3
      • CPU:
      • Skylake i7 6700k
      • Memory:
      • 16gb corsair vengeance
      • Storage:
      • 4 TB (3xHD), 3xSSD
      • Graphics card(s):
      • GTX 980ti
      • PSU:
      • tX 850w Corsair
      • Case:
      • cooler master haf92
      • Monitor(s):
      • 32" Panasonic
      • Internet:
      • "up to" 152mb

    Re: ehshell.exe crashes associated with Vista Media Centre

    Nice one..will try that myself..might give the latest 1549 tryout of ffdshow a try later to see if eliminates any of these 'DEP's.
    Is this probably why my media centre's screen goes blank when trying to access my large collection of avi's i wonder?.

  13. #12
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU

    Re: ehshell.exe crashes associated with Vista Media Centre

    Probably - it could affect explorer int the same way i'm guessing. I really think this is either my mkv / x264 / xvid codec causing the issue. If you update codecs it might be an idea to do the following:

    1. start the installer
    2. ctrl+alt+del - start task manger
    3. kill explorer.exe
    4. finish installation
    5. (in task manager) file-new task
    6. enter explorer (to restart it).

    Sometimes explorer can hang onto the codecs because it's been used to browse the files. Just a thought.
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Media Centre Spec advice please
    By Menslain in forum Consumer Electronics
    Replies: 20
    Last Post: 16-11-2006, 12:45 AM
  2. Using xbox 360 as media centre extender?
    By colincliff in forum Gaming
    Replies: 28
    Last Post: 05-10-2006, 05:45 PM
  3. ST20G5 media centre problem
    By stotten in forum PC Hardware and Components
    Replies: 4
    Last Post: 16-09-2006, 07:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •