Results 1 to 6 of 6

Thread: IX48 GT3 Tigerforce & DDR3 modules??

  1. #1
    Registered User
    Join Date
    Dec 2010
    Location
    Chatham
    Posts
    6
    Thanks
    0
    Thanked
    0 times in 0 posts

    Angry IX48 GT3 Tigerforce & DDR3 modules??

    Hi all,

    I have just got hold of an IX48 GT3 motherboard and I'm having problems booting it.

    I bought 2x 2GB DDR3 Ram sticks from PKR but it doesn't like them - I get error code "C1" Ram auto-detection error.

    I'm looking at other DDR3's on eBay but am slightly confused as to which ones are compatible with this IX48.

    PKR says I need older DDR3's rated at 1.8volt, not the newer ones I bought from them which are 1.5volt and brand name isn't an issue.

    Another dealer (Delta Trade UK) says ALL standard DDR3 Ram sticks are 1.5volt.


    Looking at some forums there does seem to be an issue with DDR3 brands and the IX48 and the only 2 names that come up consistently as compatible are Kingston or Corsair.

    So who is right??? Delta Trade or PKR?

    Acording to my Abit user manual, the voltage range is 1.30v~2.00v so on that assumption any of the DDR3 modules should work but they obviously don't!!
    Abit tech support in USA were absolutely hopeless - all they said was to make sure I use all the same brand of DDR3

    Which brands have other people used on the IX48 and worked?


    Edit:
    @Sean
    Just a thought that popped into my head... I saw on here somewhere that we can buy a newer BIOS chip for the IX48?
    If so, would a newer BIOS possibly enable me to boot with these 1.5v DDR3's??? Apparently, the default BIOS setup is 1.8v but seeing as I can't get into the BIOS to see I can't verify that - so... I'm shooting in the dark here.
    I have no idea what version I currently have coz I can't boot that far to find out but I'm willing to bet it hasn't been upgraded since it was originally shipped out!
    Last edited by freedomdwarf; 24-12-2010 at 02:35 PM. Reason: Afterthought... Newer BIOS chip?

  2. #2
    ABIT UK ABIT Sean's Avatar
    Join Date
    May 2006
    Posts
    713
    Thanks
    0
    Thanked
    17 times in 15 posts

    Re: IX48 GT3 Tigerforce & DDR3 modules??

    I don't think a bios update will make any difference. There was only one update since release and that was intended to fix a post issue, no mentioned of memory compatibility.

    Unless there was a beta that im not aware of, but as I mentioned before this was the last motherboard abit produced and very little development was ever done before abit shut down.

  3. #3
    Registered User
    Join Date
    Dec 2008
    Posts
    14
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: IX48 GT3 Tigerforce & DDR3 modules??

    I have an IX48 GT3 with BIOS 11 (original)

    Installed memory is: Kingston KVR1333D3N9K2/4G memory totals 8Gb and has been running just fine since I installed it.

  4. #4
    ODF
    ODF is offline
    Registered User
    Join Date
    Dec 2009
    Posts
    9
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: IX48 GT3 Tigerforce & DDR3 modules??

    I have an IX48 with BIOS 12

    Installed memory is: Crucial Ballistix Smart Tracer 2x BL25664ST1608RG and 2x BL25664ST1608OB that 8GB of RAM works fine.

    http://www.crucial.com/search/search...keywords=smart

    Before that Crucial RAM i used GEIL Black Dragons, the IX48 worked only with two Black Dragon modules.

  5. #5
    Registered User
    Join Date
    May 2020
    Posts
    1
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: IX48 GT3 Tigerforce & DDR3 modules??

    Hi, i had the same problem, and fixed it not with RAM but with a cpu with default value of 1066 fsb, in this case e7500 and board boots fine
    If i install e8600 , i need down clock the multipier of e7500 to 10 (default multiplier of e8600) change cpu without clear CMOS and when boot the problem persists C1 error but if I press reset the board reboot and assume there is e7500 presents and work, enter bios set optimal defaults but before exit down clock on uguru settings to 266 and save.
    It works fine, you can push up fsb to 1333 in Windows with uguru application, in my case i use 320 x 10 stable, can't use 333 x 10 but is a question of to try.
    The problem if you need to change CMOS battery, the system won't but without change cpu again, in my case this is what happens. So i use e7500 because i want to run the computer with no more problems and is not practice change CPU every time i need clear CMOS or change battery
    I use corsair vengeance 1600 without problems

  6. #6
    Registered+
    Join Date
    Apr 2020
    Posts
    46
    Thanks
    1
    Thanked
    1 time in 1 post

    Re: IX48 GT3 Tigerforce & DDR3 modules??

    Holy resurrected thread, Batman!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Second set of memory modules failed (DOMINATOR 1333)
    By JimmyBoy1 in forum Corsair Memory
    Replies: 8
    Last Post: 13-10-2010, 09:09 AM
  2. IX48 GT3 and a NIC going bad
    By ChiefZeke in forum abit.care@HEXUS
    Replies: 2
    Last Post: 04-07-2010, 02:40 AM
  3. Replies: 1
    Last Post: 04-03-2010, 02:54 PM
  4. IX48 GT3 and AHCI boot
    By ChiefZeke in forum abit.care@HEXUS
    Replies: 1
    Last Post: 03-10-2009, 05:30 AM
  5. IX48 GT3 Incorrect Temperature Reading
    By StefanH in forum abit.care@HEXUS
    Replies: 8
    Last Post: 14-04-2009, 04:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •