Results 1 to 3 of 3

Thread: Oil light flashes and beeps but levels ok...

  1. #1
    Senior Member joshwa's Avatar
    Join Date
    Jul 2003
    Location
    Shef-field, UK
    Posts
    4,820
    Thanks
    94
    Thanked
    66 times in 61 posts
    • joshwa's system
      • Motherboard:
      • PC Chips M577 AT/ATX
      • CPU:
      • AMD K6-2 500Mhz
      • Memory:
      • 512mb PC100 SDRAM
      • Storage:
      • 6.4GB Samsung
      • Graphics card(s):
      • 16mb Matrox G400 Dual Head AGP
      • PSU:
      • ATX 145watt
      • Case:
      • Midi Tower AT
      • Monitor(s):
      • 27" iiyama TFT Widescreen
      • Internet:
      • Awful horrible ADSL

    Oil light flashes and beeps but levels ok...

    On our Skoda Fabia (1.4 8v W reg) our oil light has started flashing with an audible beeping noise - it only started on friday after a 250 mile journey . I then checked the oil level and it's slightly above mid point (near max but not at max). Again it happened yesturday after about 160 miles and seems to happen when driving slower after coming off the motorway.

    We checked the car manual and it simply says "if oil level is correct take it to a skoda garage to get car checked..."

    does anyone have any ideas what this could be?

    Thanks

    Josh

  2. #2
    Senior Member
    Join Date
    Jul 2003
    Location
    leic
    Posts
    529
    Thanks
    17
    Thanked
    15 times in 15 posts
    Sounds like your oil pressure is a bit low.
    You could try a new switch first, it could be a bit weak.
    Then an oil change with an additive.
    If it still does it then it's oil pump or crankshaft?

  3. #3
    Senior Member
    Join Date
    May 2004
    Location
    Oxford
    Posts
    837
    Thanks
    46
    Thanked
    20 times in 18 posts
    • wazi's system
      • Motherboard:
      • P8H61-M PRO
      • CPU:
      • i3
      • Memory:
      • 8gb
      • Storage:
      • 6tb
      • Graphics card(s):
      • GEFORCE 650 GTX
      • PSU:
      • antec trupower
      • Case:
      • antec
      • Operating System:
      • win 10
      • Monitor(s):
      • LG
      • Internet:
      • 100 MB VIRGIN
    i would use a engine cleaner (mix with oil) and give car oil change pronto.
    sound like the oil must be black and like treacle, if it is your oil pump might be getting/blocked, when was your last oil change ? and did u use cheap oil ???

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •