Page 1 of 2 12 LastLast
Results 1 to 16 of 18

Thread: ATI Catalyst 5.8 released

  1. #1
    Member
    Join Date
    Jul 2005
    Posts
    172
    Thanks
    9
    Thanked
    5 times in 5 posts

    ATI Catalyst 5.8 released

    ATI has released the Catalyst 5.8 drivers exclusively to driverheaven.net...the drivers will be officially released tomorrow on ATI's website but DH was given a 24 hour exclusive head start.


    http://www.driverheavendownloads.net/ati.htm


    =TcQi=

  2. #2
    Senior Member Tobeman's Avatar
    Join Date
    Apr 2005
    Location
    IN YOUR FRIDGE, AWPIN' YOUR NOOBS
    Posts
    1,823
    Thanks
    34
    Thanked
    11 times in 11 posts
    Nice, will be waiting for OmegaDrivers though

  3. #3
    Sublime HEXUS.net
    Join Date
    Jul 2003
    Location
    The Void.. Floating
    Posts
    11,819
    Thanks
    213
    Thanked
    233 times in 160 posts
    • Stoo's system
      • Motherboard:
      • Mac Pro
      • CPU:
      • 2*Xeon 5450 @ 2.8GHz, 12MB Cache
      • Memory:
      • 32GB 1600MHz FBDIMM
      • Storage:
      • ~ 2.5TB + 4TB external array
      • Graphics card(s):
      • ATI Radeon HD 4870
      • Case:
      • Mac Pro
      • Operating System:
      • OS X 10.7
      • Monitor(s):
      • 24" Samsung 244T Black
      • Internet:
      • Zen Max Pro
    No changelist?

    Edit: Found it

    ATI Chipset Product Support

    The Catalyst™ software suite is designed to support the following ATI chipset products:

    * Radeon® XPRESS 200 series
    * Radeon® 9000 IGP
    * Radeon® 9100 IGP
    * Radeon® 9100 IGP Pro
    * IXP 300

    Operating systems supported

    The latest version of the Catalyst™ software suite is designed to support the following Microsoft Windows platforms:

    * Windows XP
    * Windows 2000
    * Windows Media Center Edition (graphics driver support only)

    New Features

    The latest Catalyst™ software suite provides support for COPP (Certified Output Protection Protocol) which is available in both Windows XP Service Pack 2 and the latest version of Windows Media Center 2005 (available through Microsoft Windows Update). COPP support will allow users to view high definition analog and digital content (to be released in the future) on select digital and analog displays

    Issues Resolved in Catalyst™ Software Suite 5.8

    The following section provides a summary of the issues that have been resolved in the latest version of Catalyst™. These include:

    * Battlefield 2: Geometry corruption or missing textures are no longer noticed when playing the game for an extended period of time under Windows XP with an ATI Radeon® X800 XT installed
    * 3D Mark03: Enabling Powerplay mode and running the 3DMark03 or 05 in a loop no longer results in an error message being displayed
    * Area51_2.3dc: Playing the game under Windows XP no longer results in the NPC and guns appearing distorted, flashing or missing. Further the polygons no longer pop in and out of the display
    * GTA: Vice City: Setting the desktop and the game display option to 1024x768 32bpp and attempting to play the game under Windows XP MCE, no longer results in an Invalid Pixel Format message being displayed after approximately 5 minutes of game play
    * Lineage 2: Playing the game under Windows XP no longer results in display corruption being noticed
    * Movie Maker 2: Connecting an external video source using the S-video composite connectors, no longer results in the Movie Maker 2 application intermittently failing to capture video, when selecting the Capture from Video Source
    * MU Online: Opening a chat window and playing the on-line game no longer results in hesitation being noticed when pressing the Enter key
    * Quake 3: Enabling SmartShader™ followed by attempting to do a mode change while playing the game, no longer results in the game failing to respond
    * Star Wars Knights of the Old Republic: Running the Dantoonie level of the game no longer result in hesitation being noticed
    * Terathon: Starting the Terathon 3D engine and selecting a single player demo, no longer results in the 3D engine failing to respond under Windows XP
    * Trackmania Sunrise: Playing the game under Windows XP no longer results in the operating system failing to respond, when attempting to exit the game after leaving the PC idle for an extended period of time
    * Warcraft III: Playing the game under Windows XP with the display rotated by 90 degrees CCW, no longer results in display corruption being noticed
    * Performing an overwrite of the video driver install, no longer results in the Hydravision Multidesk feature being unable to load
    * Video mode and Overscan can now be enabled when connecting a TV as the secondary display device and setting the display resolution to 640x480 32bpp 60Hz and extending the desktop
    * The Select by Signal Format is now the default setting when connecting a TV to an ATI display adapter
    * Catalyst™ Control Center: Updates to saved profiles is now available
    * Catalyst™ Control Center: Connecting a TV using the S-Video connector no longer results in the Apply button found in the TV properties of the Catalyst Control Center being active when no changes are made to the TV properties
    * Catalyst™ Control Center: An intermittent service error message is no longer displayed when starting up the Windows XP MCE operating system
    * Connecting a TV as the secondary display device and a CRT as the primary display device, no longer results in the Video mode and Overscan option not functioning properly when extended desktop is enabled
    * Catalyst™ Control Center: Double clicking anywhere on the Catalyst™ Control Center background after changing the color correction to the Full Screen 3D option no longer results in a full screen preview
    * Hesitation is no longer noticed when attempting to resume from an S3 or S4 state with Analog tv
    * Random display corruption is no longer noticed when playing a raw audio/video capture for the first time
    * Configuring Windows Media Encoder 9 as ATI AVStream Analog capture and ATI AVStream Analog Audio capture, followed by selecting a TV channel as input, no longer results in the both the Input and Output windows going black when Start Encoding is clicked
    * The DVB-T channel scan time no longer appears to be slow
    * Catalyst™ Control Center: Graphic truncation is no longer noticed under the Desktop and Display Setup of the Display Manager, in the German edition of the Catalyst Control Center
    * Catalyst™ Control Center: The text found in the Overlay/VIDEOVISION section of the Catalyst™ Control Center is no longer cut-off for the Turkish edition of the Catalyst™ Control Center
    * Setting the desktop resolution to 1024x768 32bpp and using the DVI connector to hot-plug an HDMI display device, no longer results in an error message being displayed
    * Using the ATI recommended speed option found in the Overdrive™ tab of the Catalyst™ Control Center, no longer results in the engine and memory clock values being the same as the default values
    * Using the DVI connector for a DFP display device, and the S-Video connector for a TV, no longer results in the driver returning the wrong display mappings when unplugging the DFP display device and extended desktop is enabled
    * Catalyst™ Control Center: The Set Desktop Area To, is no longer enabled and the resolution list is no longer available, when hot-unplugging a secondary display device under Windows XP
    * Playing an MPEG file on a secondary display device that is connected to the DVI port, no longer results in the lower portion of the playback window being missing
    * Hesitation in the Aquarium screen saver is no longer noticed when the ATI Multimedia Center™ is running
    * Using a limited account under Windows XP and changing the SmartShader™ aspect from none to black and white, no longer results in a general protection fault
    * Creating a custom hot-key for rotation no longer results in the custom hot-key to become unavailable for the secondary display device, when extended desktop is enabled and both display devices are set to 1280x1024

    Known Issues for Catalyst™ Software Suite 5.8

    The following section provides a brief description of known issues associated with the latest version of Catalyst™. These include the following:

    * City of Heroes: Playing the game under Windows XP Media Center Edition may results in display corruption being notice when attempting to task-switch between the game and the desktop. Further details can be found in topic number 737-19792
    * Doom3: Playing the game under Windows XP Media Center Edition may result in a noticeable performance decrease or corruption of the MCE on-screen display dialog box when lowering or muting the audio during game play. Further details can be found in topic number 737-19791
    * Grand Theft Auto: San Andreas: Geometry corruption may be noticed when running the mission under Windows XP and using the default setting for the game. Further details can be found in topic number 737-19795
    * Prince of Persia: Sands of Time: Attempting to launch the game under Windows with an ATI Radeon® X800 XL installed results in an error message being displayed. Further details can be found in topic number 737-19787
    * Rainbow six3: Athena Sword: Playing the game under Windows 2000 with an ATI Radeon® X700 installed results in the game failing to retain its resolution option of 1600x1200 if you Alt-tab out of the game and then Alt-tab back to the game. Further details can be found in topic number 737-535
    * Serious Sam: The Second Encounter: Playing the game for approximately 5 to 10 minutes under Windows XP with the game quality set at normal/default, results in display corruption being seen in the menu. Further details can be found in topic number 737-10090
    * Star Wars Jedi Knight 2: Saving a game and attempting to load the saved game under Windows XP results in the preview window display a blank preview screen. Further details can be found in topic number 737-19786
    * World of Warcraft: Enabling Full-Screen Glow in the game may result in a blue screen image being displayed when walking under water. This issue is know to occur when using an ATI Radeon® 9100 or 8500 series product. Further details can be found in topic number 737-19075
    * World of Warcraft: Display corruption is noticed when switching between the game and the Windows desktop, when the desktop is set to 1280x1024 and the graphic preferences is set to Optimal Quality. Further details can be found in topic number 737-19785
    * The Apply button in the Custom settings of the Advanced mode found under the Catalyst™ Control Center Video standard settings is grayed out when playing a media file. Further details can be found in topic number 737-497
    * Changing the DPI setting found in the General tab of the display properties to Large size (120 DPI) results in the change not taking effect when launching the Catalyst™ Control Center. Further details can be found in topic number 737-18885
    * Connecting two display devices using the DVI and CRT connectors on a system containing an ATI Xpress 200 results in the system failing to resume when entering standby state. Further details can be found in topic number 737-19538
    * The Catalyst™ Control Center may display blank pages when quickly exiting and re-launching the Catalyst™ Control Center while hot-plugging or hot-unplugging a CRT display device. Further details can be found in topic number 737-20070
    * Catalyst™ Control Center: Customizing the Catalyst™ Control Center may result in the customized logo's for the Catalyst™ Control Center not appearing on the Windows desktop or the system tray. Further details can be found in topic number 737-20071
    * Installing an All-in-Wonder® into a system containing an ATI Radeon® Xpress 200 series and an ATI Theater 550 Pro may result in loss of signal error message when setting the country region to Sweden. Further details can be found in topic number 737-20073
    * Connecting an HDTV to an ATI Radeon® X700 series may result in the HDTV being detected as a CRT or TV under the Windows XP operating system. Further details can be found in topic number 737-20074
    * Attempting to install the integrated WDM driver under Windows XP may result in an error message being displayed indicating that the hardware is not installed because the install Wizard cannot find the necessary software. Further details can be found in topic number 737-20075
    * Connecting a CRT and a TV may result in the TV not being automatically detected under Windows XP MCE when using an ATI Radeon® 9550/9600/9650 series. Further details can be found in topic number 737-20076
    * HDTV support may still be displayed within the control panel with ATI products that do not support HDTV. Further details can be found in topic number 737-20077
    * Having an HDTV connected to an ATI Xpress 200, followed by right-clicking the ATI logo on the Windows taskbar and selecting 640x432 HDTV optimized resolution results in the display mode being the same as 640x480. Further details can be found in topic number 737-20078
    * Connecting two display devices using the DVI and CRT connectors on a system containing an ATI Xpress 200 results in the system failing to resume when entering standby state. Further details can be found in topic number 737-20079
    * Catalyst™ Control Center: The Overdrive Automated Clock Configuration Utility may continue running even after the user selects apply or cancel in the utility's confirmation window. Further details can be found in topic number 737-20080
    * Catalyst™ Control Center: Connecting a TV as the only display device to an ATI Radeon® X300/X600 series may result in the Signal Format found in the Adjustment page of the TV Properties being labeled as Unknown. Further details can be found in topic number 737-20081
    * ATI Multimedia Center™: Selecting Sweden as the region in the MMC may result in the Teletext displaying incorrect text. Further details can be found in topic number 737-20089
    * Three of the four ATI entries found in the Add or Remove Programs for Windows XP Japanese version, maybe displayed in English. Further details can be found in topic number 737-20090
    Last edited by Stoo; 16-08-2005 at 09:09 PM.
    (\__/)
    (='.'=)
    (")_(")

  4. #4
    YippeeKayay Kimosabe madmaca's Avatar
    Join Date
    Jul 2003
    Location
    Staffordshire, UK
    Posts
    649
    Thanks
    1
    Thanked
    8 times in 8 posts
    Nice one - downloading....

    1 wheel > 2 wheels > 4 wheels | My Photos

  5. #5
    Hexus.net Troll Dougal's Avatar
    Join Date
    Jun 2005
    Location
    In your eyeball.
    Posts
    2,750
    Thanks
    0
    Thanked
    0 times in 0 posts
    Got mine

    Gonna install after i finish watching lost.

    I tried the omegas on my system last week.

    Happy hours trying to get my comp working.
    Quote Originally Posted by Errr...me
    I MSN offline people
    6014 3DMk 05

  6. #6
    hi unreal's Avatar
    Join Date
    Jan 2005
    Location
    East London & Birmingham City Uni
    Posts
    3,657
    Thanks
    14
    Thanked
    37 times in 30 posts
    • unreal's system
      • Motherboard:
      • Intel iMac 20" & Macbook
      • CPU:
      • Intel Core 2 Duo T7200 2.0Ghz
      • Memory:
      • 4gb DDR667
      • Storage:
      • 1TB 7200 Int + 1.5Tb Ext
      • Graphics card(s):
      • ATi Radeon 2400XT
      • PSU:
      • 95W or something?
      • Case:
      • Intel iMac 20" Aluminium
      • Operating System:
      • OSX Snow Leopard (Win 7 x64 on Macbook Bootcamp)
      • Monitor(s):
      • 20" @ 1680x1050 & 27" 1080p HDTV
      • Internet:
      • O2 10mb
    Can't be bothered for two restarts, so I will give it a shot when its convinient lol... thanks for the heads up.

    Kinda happy with my Omega drivers at the mo tbh

  7. #7
    Registered User
    Join Date
    Aug 2005
    Posts
    11
    Thanks
    0
    Thanked
    0 times in 0 posts
    I know that Nvidia has the high end graphics market locked up hardware wise right now but I still like the way ATI does their driver releases much better; they come at regular intervals and they have an excellent changelist. I wouldn't say the drivers are necessarily better but ATI seems to be much more involved with the community. /bow

  8. #8
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU
    Are these the ones with CATALYST Control Center being the only option? I hate .NET slothware
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


  9. #9
    Member
    Join Date
    Nov 2003
    Location
    scunthorpe
    Posts
    110
    Thanks
    0
    Thanked
    0 times in 0 posts
    i wonder if all the BF2 problems are solved, i couldnt see any walls with the 5.7.

    i had to go back to the 5.6 omegas

  10. #10
    OMG!! PWND!!
    Join Date
    Dec 2003
    Location
    In front of computer
    Posts
    964
    Thanks
    0
    Thanked
    0 times in 0 posts
    Quote Originally Posted by jarvo
    i wonder if all the BF2 problems are solved, i couldnt see any walls with the 5.7.

    i had to go back to the 5.6 omegas
    As Stoo's post said:

    * Battlefield 2: Geometry corruption or missing textures are no longer noticed when playing the game for an extended period of time under Windows XP with an ATI Radeon® X800 XT installed

  11. #11
    Studmuffin Flibb's Avatar
    Join Date
    Jul 2003
    Location
    Kent
    Posts
    4,904
    Thanks
    31
    Thanked
    324 times in 277 posts
    • Flibb's system
      • Motherboard:
      • Gigabyte GA-970A-UD3
      • CPU:
      • AMD FX-6300
      • Memory:
      • 16GB Crucial Ballistix DDR3 PC3-12800
      • Storage:
      • Samsung SSD 840 EVO 250G
      • Graphics card(s):
      • 3GB MSI Radeon HD 7950 Twin Frozr
      • PSU:
      • FSP
      • Operating System:
      • Win7 64bit
      • Monitor(s):
      • Deffl TFT thing
    Quote Originally Posted by Applecrusher
    As Stoo's post said:

    I AM having the same problem with walls, although my gpu is a 9800pro
    Last edited by Flibb; 17-08-2005 at 02:46 PM.

  12. #12
    Senior Member
    Join Date
    May 2004
    Location
    Essex
    Posts
    2,435
    Thanks
    0
    Thanked
    4 times in 2 posts
    • BenW's system
      • Motherboard:
      • ASRock Dual SATA2
      • CPU:
      • AMD64 3500+
      • Memory:
      • 1GB Crucial DDR
      • Storage:
      • 160GB Samsung 8MB Cache
      • Graphics card(s):
      • Sapphire Radeon HD 3850
      • PSU:
      • Seasonic S12 600W
      • Case:
      • Silverstone TJ-04
      • Monitor(s):
      • Dell 17" Ultrasharp
      • Internet:
      • Virgin 8Mb
    Nothing of any interest to me at the moment. Will update when i get BF2

  13. #13
    Registered+
    Join Date
    Jul 2005
    Posts
    29
    Thanks
    0
    Thanked
    0 times in 0 posts
    i'll wait for the omega ones too. i have a laptop so its less hassle to use omega.

  14. #14
    hi unreal's Avatar
    Join Date
    Jan 2005
    Location
    East London & Birmingham City Uni
    Posts
    3,657
    Thanks
    14
    Thanked
    37 times in 30 posts
    • unreal's system
      • Motherboard:
      • Intel iMac 20" & Macbook
      • CPU:
      • Intel Core 2 Duo T7200 2.0Ghz
      • Memory:
      • 4gb DDR667
      • Storage:
      • 1TB 7200 Int + 1.5Tb Ext
      • Graphics card(s):
      • ATi Radeon 2400XT
      • PSU:
      • 95W or something?
      • Case:
      • Intel iMac 20" Aluminium
      • Operating System:
      • OSX Snow Leopard (Win 7 x64 on Macbook Bootcamp)
      • Monitor(s):
      • 20" @ 1680x1050 & 27" 1080p HDTV
      • Internet:
      • O2 10mb

    Question

    Quote Originally Posted by allankyoto
    I know that Nvidia has the high end graphics market locked up hardware wise right now but I still like the way ATI does their driver releases much better; they come at regular intervals and they have an excellent changelist. I wouldn't say the drivers are necessarily better but ATI seems to be much more involved with the community. /bow

    Don't the nvidia drivers come out almost weekly? They also 'leak' beta drivers too... you have literally hundreds of different drivers you can use with a geforce based card lol

  15. #15
    Registered User
    Join Date
    Aug 2005
    Posts
    11
    Thanks
    0
    Thanked
    0 times in 0 posts
    "Don't the nvidia drivers come out almost weekly? They also 'leak' beta drivers too... you have literally hundreds of different drivers you can use with a geforce based card lol"

    Yeah that's just what I want, hundreds of different drivers (including beta drivers) with no idea what is fixed and what isn't. We don't know if they were hacked at Joe Blow's KOOL Hardware shop along the way as well. Yeah let's install those, that'll make Winblows even more reliable. /rolleyes
    Last edited by allankyoto; 17-08-2005 at 04:19 PM.

  16. #16
    Hexus.net Troll Dougal's Avatar
    Join Date
    Jun 2005
    Location
    In your eyeball.
    Posts
    2,750
    Thanks
    0
    Thanked
    0 times in 0 posts
    Just a quick question:

    Since I installed 5.8 MSN messenger keeps stalling.

    Is it just me or has anyone else had the prob?
    Quote Originally Posted by Errr...me
    I MSN offline people
    6014 3DMk 05

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ATI CATALYST 5.7 Released
    By Steve in forum HEXUS News
    Replies: 6
    Last Post: 21-07-2005, 06:27 PM
  2. ATI Catalyst Report - Q2
    By Nick in forum HEXUS News
    Replies: 3
    Last Post: 21-06-2005, 07:43 PM
  3. ATI Catalyst 5.5 Available
    By Steve in forum HEXUS News
    Replies: 5
    Last Post: 18-05-2005, 10:00 PM
  4. ATi CATALYST 5.4 software suite
    By Steve in forum HEXUS News
    Replies: 13
    Last Post: 12-04-2005, 05:27 AM
  5. ATi CATALYST Top 10 Tips
    By DR in forum Graphics Cards
    Replies: 7
    Last Post: 04-02-2005, 09:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •