Page 1 of 3 123 LastLast
Results 1 to 16 of 48

Thread: Gainward rma, pfffft

  1. #1
    Senior Member
    Join Date
    Aug 2003
    Posts
    251
    Thanks
    0
    Thanked
    0 times in 0 posts

    Gainward rma, pfffft

    little rant about gainward and the RMA service...

    Sent a card to gainward (one of those dodgy ti4200's) to be rma'd on 21/09/03. Apparently a replacement card was dispatched on the 13/11/03. 22 days later and i've still recieved nothing. I tried e-mailing for a tracking number, no response.

    I've spoken to Andy from the UK office, and he'll say he will look into it, but i havn't heard from him in 3 days. I know its got to come from germany, but surely is doesn't take 22 days? All i want is a tracking number ffs At least then i cud chase this up my self

    It may not be gainward's fault, but seeing as the cards are posted by UPS (according to andy) then surely a tracking number isn't too much to ask? Havn't heard from support in germany since 21/11/03. Im not very impressed to say the least.

    Any one else had to rma a gainward to germany before? Did it take THIS long?

  2. #2
    Banned
    Join Date
    Jul 2003
    Location
    House without a red door in Birmingham
    Posts
    1,595
    Thanks
    0
    Thanked
    0 times in 0 posts
    I have heard Gainward's customer service is certainly somewhat lower than most expect ... CS is one thing that seems to get worse and worse in this industry. On a good note both Maxtor and Connect3D are still known to be top notch, very quick turn around and prompt comms.

    Next time don't buy Gainward and warn others to consider the alternatives. IMHO Gainward haven't been the same since the GF3 days.

  3. #3
    cat /dev/null streetster's Avatar
    Join Date
    Jul 2003
    Location
    London
    Posts
    4,138
    Thanks
    119
    Thanked
    100 times in 82 posts
    • streetster's system
      • Motherboard:
      • Asus P7P55D-E
      • CPU:
      • Intel i5 750 2.67 @ 4.0Ghz
      • Memory:
      • 4GB Corsair XMS DDR3
      • Storage:
      • 2x1TB Drives [RAID0]
      • Graphics card(s):
      • 2xSapphire HD 4870 512MB CrossFireX
      • PSU:
      • Corsair HX520W
      • Case:
      • Coolermaster Black Widow
      • Operating System:
      • Windows 7 x64
      • Monitor(s):
      • DELL U2311
      • Internet:
      • Virgin 50Mb
    my friend blockers is in the process of RMAing his card, i'll get him to post here later , he's tracked the shipment to germany (and it arrived) cos he posted it RMSD, but he's still waiting for the card back (afaik).

    surely having a gainward representative on the boards should help with any issues

    mark

  4. #4
    Senior Member
    Join Date
    Jul 2003
    Location
    Petersfield, UK
    Posts
    1,755
    Thanks
    0
    Thanked
    0 times in 0 posts
    Well it stil hasnt arrived, im going to play some nfs:underground for about 3 months then, until it does
    | XP1600-m | ASUS AN78X Deluxe | r9700 pro | 2x512mb pc37000 |

  5. #5
    Title Contender
    Join Date
    Aug 2003
    Posts
    1,674
    Thanks
    3
    Thanked
    0 times in 0 posts
    what do you need to RMA one of these

    and are you all RMA'n yours due to the pink screen thingy!

    this only happens on mine when the PC gets cold i.e left on overnight in my conservatory!

  6. #6
    Senior Member
    Join Date
    Aug 2003
    Posts
    251
    Thanks
    0
    Thanked
    0 times in 0 posts
    flash u need to get an rma number from gainward, then you have to post ur card off to germany. Dont expect to see your card anytime soon tho...

    blockers how long have you been waiting so far?

  7. #7
    Senior Member
    Join Date
    Jul 2003
    Location
    Petersfield, UK
    Posts
    1,755
    Thanks
    0
    Thanked
    0 times in 0 posts
    29th October was the date that i posted it i think. I did email them last week some time, asking how long it takes to RMA a card, and where mine is in the process. I got an emial back the same day, or the day after asking me which RMA, i had forgotten to write it in the email (d'oh.) So i emialed them again, with the RMA and havent heard back from them...

    Will
    | XP1600-m | ASUS AN78X Deluxe | r9700 pro | 2x512mb pc37000 |

  8. #8
    Senior Member
    Join Date
    Aug 2003
    Posts
    251
    Thanks
    0
    Thanked
    0 times in 0 posts
    Its pretty crap tbh, surely support have time to check their e-mail once every couple of days? Might try and ring Andy Davies on monday. Im really starting to get pissed off now....

  9. #9
    HEXUS.social member Agent's Avatar
    Join Date
    Jul 2003
    Location
    Internet
    Posts
    19,159
    Thanks
    732
    Thanked
    1,605 times in 1,044 posts
    Originally posted by Austin
    IMHO Gainward haven't been the same since the GF3 days.


    Quote Originally Posted by Saracen View Post
    And by trying to force me to like small pants, they've alienated me.

  10. #10
    Senior Member
    Join Date
    Aug 2003
    Posts
    251
    Thanks
    0
    Thanked
    0 times in 0 posts
    Just sent an e-mail to the gainward head office..


    Dear Sir / Madam

    Recently I tried to RMA a graphics card (ti4200) to your Germany office. I was told my replacement card was posted to me on the 13/11/03. Its now 22 days later and I’ve still received nothing. I've tried e-mailing support but they don’t reply to my mails anymore, a tracking number for the parcel would be good so I can chase this up my self. I haven’t heard from support in about a week. I've mentioned this on several discussion forums, that of www.hexus.net and www.bit-tech.net . I know of two other people who have also had similar experiences with your RMA procedure, and have posted there experiences on similar discussion forums. The threads in question are -

    http://forums.bit-tech.net/showthrea...0&pagenumber=1 (page 4 onwards, my user name is Shepps) This thread had over 1850 views so far, and will only get more views the longer this is left un resolved.

    http://forums.hexus.net/showthread.php?threadid=6285 and also https://forums.hexus.net/graphics-cards/8871-gainward-rma-pfffft.html

    All I want is my replacement graphics card. It’s been 44 days since I posted my faulty card to Germany, and for me, waiting this long for a card is both unacceptable and a disgrace to your company. You make brilliant cards, it’s just a shame your after sales support is so poor.

    Yours Sincerely,

    George Sheppard

  11. #11
    Senior Member
    Join Date
    Aug 2003
    Posts
    251
    Thanks
    0
    Thanked
    0 times in 0 posts
    blockers what ur e-mail please? i have some interesting news

  12. #12
    One skin, two skin......
    Join Date
    Jul 2003
    Location
    Durham
    Posts
    1,705
    Thanks
    0
    Thanked
    1 time in 1 post
    What's this intreresting news?????? I wanna hear!!!!!

  13. #13
    Senior Member
    Join Date
    Aug 2003
    Posts
    251
    Thanks
    0
    Thanked
    0 times in 0 posts
    Just had an e-mail from the Europe marketing and sales director. And also the head bloke in germany. There both looking into it. Hopefully they'll be able to sort this mess out

  14. #14
    Nox
    Nox is offline
    Vorsprung durch Technik
    Join Date
    Oct 2003
    Location
    Hampshire
    Posts
    2,023
    Thanks
    2
    Thanked
    2 times in 2 posts
    • Nox's system
      • Motherboard:
      • Yes
      • CPU:
      • Yes
      • Memory:
      • Yes
      • Storage:
      • Yes
      • Graphics card(s):
      • Yes
      • PSU:
      • Yes
      • Case:
      • Yes
      • Monitor(s):
      • Yes
      • Internet:
      • Yes
    good grief! you can't not share something like that!!!

    Nox

  15. #15
    Senior Member
    Join Date
    Aug 2003
    Posts
    251
    Thanks
    0
    Thanked
    0 times in 0 posts
    I just hope they sort this out, i cba with waiting any longer.

  16. #16
    Member
    Join Date
    Oct 2003
    Location
    Dublin, Ireland.
    Posts
    136
    Thanks
    0
    Thanked
    0 times in 0 posts
    yeah post the email you got!
    Shuttle SB61G2 Anniversary Ed
    P4 2.6GHz
    2x256MB OCZ 3200 DDR
    TYAN Tachyon Radeon 9600 Pro
    60GB Seagate 'cuda IV 7200
    10GB IBM 5400
    other boring peripherals

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •