Results 1 to 5 of 5

Thread: My monitor keeps hissing :/

  1. #1
    hi unreal's Avatar
    Join Date
    Jan 2005
    Location
    East London & Birmingham City Uni
    Posts
    3,657
    Thanks
    14
    Thanked
    37 times in 30 posts
    • unreal's system
      • Motherboard:
      • Intel iMac 20" & Macbook
      • CPU:
      • Intel Core 2 Duo T7200 2.0Ghz
      • Memory:
      • 4gb DDR667
      • Storage:
      • 1TB 7200 Int + 1.5Tb Ext
      • Graphics card(s):
      • ATi Radeon 2400XT
      • PSU:
      • 95W or something?
      • Case:
      • Intel iMac 20" Aluminium
      • Operating System:
      • OSX Snow Leopard (Win 7 x64 on Macbook Bootcamp)
      • Monitor(s):
      • 20" @ 1680x1050 & 27" 1080p HDTV
      • Internet:
      • O2 10mb

    My monitor keeps hissing :/

    I have a Feb A01 (I think) 2005 model of the Dell 2005FPW TFT screens. This one was a brand new replacement after my first one got replaced due to backlight leakage.

    Ever since I've had it, it has hissed a few times before, especially when I use the USB ports on it or anything - I didn't really need them so I didn't mind and just avoided using it's built in hub.

    I've been using the USB hub since Sept 06, ever since I got my new phone since I've had a card reader attached to it.

    Within the last two weeks its been hissing ALL the time. It's like when you've had your speakers on really loud, and then you don't play any music or anything and you get a fairly loud white noise. It's that exact sort of sound. It tends to happen now after the monitor has been on for about an hour, and once it happens I have to take to power plug out and leave it off for a bit.

    I gave the dates because I'm wondering if I'm still on the Dell warranty? I would have opened it up but if its a PSU problem (which it sounds like it is), then I can't really do anything to fix that.

    I can't find how to contact dell bizarrely. I can't even find any receipt for my monitor at the moment, although it may be on my fathers email account etc.

    Also, is this hissing much danger to the monitor or anything? Sometimes I just get annoyed and leave it hissing while I use it for the day.

  2. #2
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    Quote Originally Posted by unreal View Post
    I can't find how to contact dell bizarrely.
    Ring them up and shout wobbly kack.

    Alternatively, contact them here.
    Last edited by Clunk; 21-04-2007 at 07:56 PM.
    Quote Originally Posted by Blitzen View Post
    stupid betond belief.
    You owe it to yourself to click here really.

  3. #3
    hi unreal's Avatar
    Join Date
    Jan 2005
    Location
    East London & Birmingham City Uni
    Posts
    3,657
    Thanks
    14
    Thanked
    37 times in 30 posts
    • unreal's system
      • Motherboard:
      • Intel iMac 20" & Macbook
      • CPU:
      • Intel Core 2 Duo T7200 2.0Ghz
      • Memory:
      • 4gb DDR667
      • Storage:
      • 1TB 7200 Int + 1.5Tb Ext
      • Graphics card(s):
      • ATi Radeon 2400XT
      • PSU:
      • 95W or something?
      • Case:
      • Intel iMac 20" Aluminium
      • Operating System:
      • OSX Snow Leopard (Win 7 x64 on Macbook Bootcamp)
      • Monitor(s):
      • 20" @ 1680x1050 & 27" 1080p HDTV
      • Internet:
      • O2 10mb
    Quote Originally Posted by Clunk View Post
    Ring them up and shout wobbly kack.

    Alternatively, contact them here.
    Thanks mate, you're awesome

    I also realised I still had the USB host cable connected which still made the hub demand power from the monitor, I disconnected it and it hasn't made any noise since. However I'm still gonna call em up and see whats up.

  4. #4
    honed at getting pwned
    Join Date
    Sep 2006
    Location
    Lancashire, UK
    Posts
    449
    Thanks
    4
    Thanked
    4 times in 4 posts
    My old IBM ThinkPad screen plays a pretty tune when you access the harddrive, I have no idea why but it's way out of warranty...

  5. #5
    Senior Member Pob255's Avatar
    Join Date
    Apr 2007
    Location
    The land of Brum
    Posts
    9,945
    Thanks
    572
    Thanked
    1,196 times in 1,099 posts
    • Pob255's system
      • Motherboard:
      • Asus M5A99X EVO
      • CPU:
      • PhenomII x4 955 & CM Hyper 212+
      • Memory:
      • 2x 4gb Corsair Vengence 1600mhz cas9
      • Storage:
      • 250gb SATA Westerndigital + 500gb samsung +1tb Samsung
      • Graphics card(s):
      • Asus GTX560ti CuII
      • PSU:
      • Be Quiet E9 680w
      • Case:
      • HAF 912+
      • Operating System:
      • W7 Pro
      • Monitor(s):
      • Dell 21" ips something
    if you bought your monitor as part of a pc bundel it will have a service tag sticker, if you put that number in here that will tell you the current state & details of your warranty.

    if your service tag sticker is missing the number is also shown in the BIOS.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Megaworks 550's hissing! Annoyin!
    By ja3h in forum Help! Quick Relief From Tech Headaches
    Replies: 3
    Last Post: 29-09-2005, 11:15 PM
  2. TOCA Race Driver 2 - Sound Hissing?
    By MD in forum Gaming
    Replies: 1
    Last Post: 01-06-2004, 07:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •