Results 1 to 4 of 4

Thread: Sharing files and printer on the network :-(

  1. #1
    Join Date
    Sep 2003
    In a house, a very big house in the country
    0 times in 0 posts

    Sharing files and printer on the network :-(

    Hi, there are currently two pc's in my house, mine and my sisters, connected to broadband via a Linksys Router and the printer is connected to my sisters pc. They always used to share files fine but then I came to print something the other day and couldn't and I also noticed that I couldn't see any of my sisters shared files and vice versa, it just seems as though the two computers don't see each other! I have tried the Network setup wizard but that just made my internet stop working as it changed all the connection properties! I have also checked that the workgroups are the same for both pcs and they are. Like I said, they used to work fine! Any suggestions would be greatful!


    Intel Core 2 Quad Q6600 - 4GB RAM - XFX NVIDIA GeForce 8800 384MB - NEC Optiarc 20x Lightscribe DVD+/-RW/RAM - Windows 7

  2. #2
    I have a tenner sat here (metaphorically at least) that says you have a firewall on one or both PCs that's stopping your file and printer sharing. Test this theory by trying to ping one machine's hostname from the other, then pinging one machine's ip address from the other. If neither work you're pretty much looking at a firewall config issue.

  3. #3
    Senior Member
    Join Date
    Jan 2006
    7 times in 7 posts
    • ash_rm's system
      • Motherboard:
      • Gigabyte P35-S3
      • CPU:
      • E4300@3.2GHz
      • Memory:
      • 2x 2GB Corsair
      • Storage:
      • 320GB WD & 80GB Maxtor
      • Graphics card(s):
      • 7600GT
      • PSU:
      • Seasonic S12 380W
      • Case:
      • Antec Solo
      • Monitor(s):
      • DGM 24" (1920 x 1200)
      • Internet:
      • Be (~ 3mb)
    Has anything changed on that network? New Router or something? Anti-Virus Software?

    Otherwise sounds like a firwall is on one or both of the PC's as Splash says.

    If its the Windows firewall and you wish to keep it on, you could add file and printer sharing in the exceptions list.

    If you have Norton, Zone Alarm etc check the settings.

  4. #4
    Senior Member
    Join Date
    Sep 2005
    7 times in 7 posts
    Try doing the following on both computers:

    Go to START > CONTROL PANEL > NETWORK CONNECTIONS and delete any bridges you see.

    Then run the Network Setup Wizard. Select the option "this computer accesses the Internet through another computer on my network" -- or something similar (I forget the exact wording). This "other computer" is, in fact, your router.

    Then, as you work through the wizard, pressing Next, you will see an option to "turn on file and printer sharing". Turn it on. Then finish the wizard.

    Lastly, go to the WinXP firewall settings (START > CONTROL PANEL > WINDOWS FIREWALL), and tick the checkbox for File and Printer Sharing to allow it as an exception. In fact, you can probably just turn the whole firewall off for the moment as a test, since you are already behind a router with a built-in hardware firewall.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XP/98 Network
    By ajbrun in forum Networking and Broadband
    Replies: 11
    Last Post: 30-07-2005, 05:27 PM
  2. network printer problems.
    By philip41 in forum Software
    Replies: 0
    Last Post: 30-12-2004, 07:56 PM
  3. No network places - what've i done wrong?
    By subucni in forum Networking and Broadband
    Replies: 2
    Last Post: 08-12-2004, 11:41 PM
  4. printer / file sharing help
    By petrefax in forum Networking and Broadband
    Replies: 15
    Last Post: 04-03-2004, 02:48 PM
  5. Can't access folders or printers from my laptop on network
    By TomWilko in forum Networking and Broadband
    Replies: 15
    Last Post: 02-12-2003, 09:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts