Results 1 to 13 of 13

Thread: ASUS P5B & KINGSTON KHX6400D2/1G HYPERX PC6400 800 recognised as PC2-5300!

  1. #1
    Senior Member retroborg's Avatar
    Join Date
    Aug 2003
    Posts
    657
    Thanks
    19
    Thanked
    17 times in 11 posts

    ASUS P5B & KINGSTON KHX6400D2/1G HYPERX PC6400 800 recognised as PC2-5300!

    Hello,
    I recently bought a new Mother Board (ASUS P5B) & Core 2 Duo 6600 @ 2.4GHZ:

    ASUS P5B:
    http://www.asus.com/products4.aspx?l...78&modelmenu=1

    I installed the following Ram:
    KINGSTON KHX6400D2/1G HYPERX 1GB PC6400 800MHZ
    http://www.e-shop.gr/show_per.phtml?id=PER.554789

    But, when the system boots up, at the American Megatrends Bios DOS screen, the memory is recognized as:
    PC2-5300 667MHz and not PC2-6400 800MHZ!

    I updated the Bios to 1007 from here:
    http://support.asus.com/download/dow...n-us&model=P5B

    But the same problem persists!

    I read in the manual:
    http://support.asus.com/download/dow...n-us&model=P5B


    Due to chipset limitation, DDR2-800 with CL=4 will be downgraded to run at DDR2-667 by default setting. If you want to operate with lower latency, adjust the memory timing manually.

    Some old-version DDR2-800/667 DIMMs, may not match Intel's On-Die-Termination (ODT) requirement and will automatically downgrade to run at DDR2-533. If this happens, contact your memory vendor to check the ODT value.

    I can’t find any section on the BIOS menu where I could adjust the memory tiomings manually?!
    But this specific Kingston RAM is mentioned as CL5, with timings:5-5-5-15, so this shouldn’t be happening!?

    Also, in the manual, at the P5B Premium Series M/B Qualified Vendors List (QVL) DD2-800MHZ capability, Kingston 1GB DDR2-800MHZ is listed, but not my specific KINGSTON KHX6400D2/1G HYPERX 1GB PC6400 800MHZ model.

    Is there any solution to this problem or should I change the brand of the RAM or even the M/B?
    Please, any help will be highly appreciated!

    Thanks in advance.

  2. #2
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    chipset/northbridge/by spd = disabled

    That will let you manually set the timings. The board will be reading the SPD, so you need to manually enter everything.
    Quote Originally Posted by Blitzen View Post
    stupid betond belief.
    You owe it to yourself to click here really.

  3. #3
    Senior Member retroborg's Avatar
    Join Date
    Aug 2003
    Posts
    657
    Thanks
    19
    Thanked
    17 times in 11 posts
    OK, got it!
    It was in the Advanced, "JumperFree Configuration", you can set the DRAM frequency to DDR-800MHZ, 889MHZ, even up to 1066MHZ!

    Cool!
    Me Happy!

  4. #4
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    Youll still need to set the timings manually.
    Quote Originally Posted by Blitzen View Post
    stupid betond belief.
    You owe it to yourself to click here really.

  5. #5
    Senior Member retroborg's Avatar
    Join Date
    Aug 2003
    Posts
    657
    Thanks
    19
    Thanked
    17 times in 11 posts
    OK, Thanks!
    So, I disabled the spd in the Chipset/Northbridge menu and set the DRAM CL=5. (It was all ready CL=5 by default)

    But, there are a few other fields in this menu, which I’m not familiar with:

    Memory Remap Feature = [Disabled]
    Configure DRAM Timing by SPD = [Disabled]
    DRAM CAS# Latency = [5]
    DRAM RAS# Precharge = [6 DRAM Clocks]
    DRAM RAS# to CAS# Delay = [6 DRAM Clocks]
    DRAM RAS# Activate to Precharge = [15 DRAM Clocks]
    DRAM Write Recovery Time = [6 DRAM Clocks]
    DRAM TRFC = [42 DRAM Clocks]
    DRAM TRRD = [10]
    RANK Write To Read Delay = [10]
    Read To Precharge Delay = [10]
    Write To Precharge Delay = [10]
    Static Read Control = [Auto]
    Initiate Graphic Adapter PEG/PCI

    REG Port Configuration
    REG Force x 1 = [Disabled]

    But since I’m not sure what they’re used for, I left them as they are.


    But, shouldn't it be:
    DRAM CAS# Latency = [5]
    DRAM RAS# Precharge = [5 DRAM Clocks]
    DRAM RAS# to CAS# Delay = [5 DRAM Clocks]
    DRAM RAS# Activate to Precharge = [15 DRAM Clocks]

    In order to achieve the factory Timings: 5-5-5-15 of this specific Kingston RAM?

    What do you suggest?

    Also in the Jumperfree menu, there is this field:

    AI Tuning = [Auto]
    If set to manual, you can change the CPU frequency/voltage, PCI frequency, etc…

    Thanks in advance.
    Last edited by retroborg; 30-01-2007 at 08:09 AM.

  6. #6
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    Quote Originally Posted by retroborg View Post
    OK, Thanks!
    So, I disabled the spd in the Chipset/Northbridge menu and set the DRAM CL=5. (It was all ready CL=5 by default)

    But, there are a few other fields in this menu, which I’m not familiar with:

    Memory Remap Feature = [Disabled] disabled
    Configure DRAM Timing by SPD = [Disabled] disabled
    DRAM CAS# Latency = [5] 5
    DRAM RAS# Precharge = [6 DRAM Clocks] 5
    DRAM RAS# to CAS# Delay = [6 DRAM Clocks] 5
    DRAM RAS# Activate to Precharge = [15 DRAM Clocks] 15
    DRAM Write Recovery Time = [6 DRAM Clocks] check what the manufacturer recommends
    DRAM TRFC = [42 DRAM Clocks]check what the manufacturer recommends
    DRAM TRRD = [10]check what the manufacturer recommends
    RANK Write To Read Delay = [10] check what the manufacturer recommends
    Read To Precharge Delay = [10] check what the manufacturer recommends
    Write To Precharge Delay = [10] check what the manufacturer recommends
    Static Read Control = [Auto] leave on auto
    Initiate Graphic Adapter PEG/PCI

    REG Port Configuration
    REG Force x 1 = [Disabled]

    But since I’m not sure what they’re used for, I left them as they are.


    But, shouldn't it be:
    DRAM CAS# Latency = [5]
    DRAM RAS# Precharge = [5 DRAM Clocks]
    DRAM RAS# to CAS# Delay = [5 DRAM Clocks]
    DRAM RAS# Activate to Precharge = [15 DRAM Clocks]

    In order to achieve the factory Timings: 5-5-5-15 of this specific Kingston RAM?

    What do you suggest?

    Also in the Jumperfree menu, there is this field:

    AI Tuning = [Auto]
    If set to manual, you can change the CPU frequency/voltage, PCI frequency, etc…

    Thanks in advance.
    The rest is ok.

    Some of the timings that are set to 10, sometimes they will need to be changed if you are having problems getting stable in memtest.
    Quote Originally Posted by Blitzen View Post
    stupid betond belief.
    You owe it to yourself to click here really.

  7. #7
    Senior Member retroborg's Avatar
    Join Date
    Aug 2003
    Posts
    657
    Thanks
    19
    Thanked
    17 times in 11 posts
    OK, so I disabled SPD and set the right timings: 5,5,5,15 and in the Advanced, "Jumper Free Configuration", I set the DRAM frequency to DDR-800MHZ, so when the system boots up, (at the American Megatrends Bios DOS screen), the memory is indeed recognized as:
    PC2-6400 800MHZ and not PC2-5300 667MHz.

    But I noticed that when I use CPU-Z 1.38, in the “SPD” field, the two DDR-2 modules are recognised as PC2-5300 (333MHZ)?


    Where as in the “Memory” field, the frequency and timings are right: 400MHZ, timings: 5,5,5,15


    Also, the ASUS P5B-E P965 M/B uses an ICH8R Southbridge chipset, but CPU-Z 1.38 recognizes it as ICH8?


    Is there anything wrong with my Bios setting that leads CPU-Z in wrongfully recognizing the memory type & chipset?

    Thanks in advance.

  8. #8
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    Maybe cpu-z needs an update. Maybe your ram really is 5300?

    Sometimes if you buy fast ram that hasnt yet got a Jedec specification, the SPD will show it as the highest previous rated type. So, for example, lets say that pc2-6400 hadnt yet been formally approved as a spec, then even ram that was rated to run at pc2-6400 would still carry pc2-5300 in its SPD.

    Im not saying that this is what has happened with yours (date of manufacture rules that out), but if it runs at the speed that it should, then dont worry about it

    edit: Mine shows as 6400 when really it is 9200.
    Quote Originally Posted by Blitzen View Post
    stupid betond belief.
    You owe it to yourself to click here really.

  9. #9
    Senior Member retroborg's Avatar
    Join Date
    Aug 2003
    Posts
    657
    Thanks
    19
    Thanked
    17 times in 11 posts
    Quote Originally Posted by Clunk View Post
    Maybe your ram really is 5300?.
    No, these are PC2-6400 Kingston HyperX 1GB 800MHZ Dimms.

    Sometimes if you buy fast ram that hasnt yet got a Jedec specification, the SPD will show it as the highest previous rated type. So, for example, lets say that pc2-6400 hadnt yet been formally approved as a spec, then even ram that was rated to run at pc2-6400 would still carry pc2-5300 in its SPD.
    I think this would be the case.



    But what about the ICH8R Southbridge chipset, being recognized as ICH8?

  10. #10
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    Quote Originally Posted by retroborg View Post
    But what about the ICH8R Southbridge chipset, being recognized as ICH8?
    Dunno about that, mine also says ICH8....wait for version 1.39 maybe?
    Quote Originally Posted by Blitzen View Post
    stupid betond belief.
    You owe it to yourself to click here really.

  11. #11
    Pedandic mo-fo IAmATeaf's Avatar
    Join Date
    Jul 2006
    Location
    South of the Watford Gap!
    Posts
    896
    Thanks
    0
    Thanked
    11 times in 11 posts
    • IAmATeaf's system
      • Motherboard:
      • Asus P5Q Deluxe
      • CPU:
      • Q6600@3.25
      • Memory:
      • 4 x 2GB Corsair 6400C5DHX XMS2
      • Storage:
      • 2 x 0.5TB 7200.12, 2 x 1.5TB 7200.11
      • Graphics card(s):
      • Gigabyte GTX460 OC
      • PSU:
      • Corsair HX520
      • Case:
      • Lian Li PC6089B
      • Operating System:
      • Windows 7 Pro x64
      • Monitor(s):
      • Samsung T240 24"
      • Internet:
      • 6Mb ADSL Max
    Quote Originally Posted by retroborg View Post
    But what about the ICH8R Southbridge chipset, being recognized as ICH8?
    Seen loads of posts on this on this and other sites, nothing to worry about is the general answer.

  12. #12
    Senior Member retroborg's Avatar
    Join Date
    Aug 2003
    Posts
    657
    Thanks
    19
    Thanked
    17 times in 11 posts
    Well, there is a new version CPU-Z 1.39:
    http://www.softpedia.com/get/System/...fo/CPU-Z.shtml

    It recognizes the ICH8R southbridge chipset, but it still says:
    pc2-5300 instead of PC2-6400.

  13. #13
    Registered User
    Join Date
    Jun 2008
    Posts
    1
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: ASUS P5B & KINGSTON KHX6400D2/1G HYPERX PC6400 800 recognised as PC2-5300!

    I know this post is a little older, but here is some info that I dug up about this exact issue. I got this data direct from kingston.com:

    Some motherboard BIOS may need to be manually adjusted. There are over a million different combinations available. The most common are those that help DRAM speed, DRAM timings, and voltage. CLICK HERE for the proper settings.
    Further, when digging even deeper, I found this statemenet for this exact model memory chip (KHX6400D2/1G):

    This module has been tested to run at DDR2 800MHz at low latency timing of 5-5-5-15 at 2.0V. The
    SPD is programmed to JEDEC standard latency 667Mhz timing of 5-5-5-15 at 1.8V.
    Hope this helps in case anyone else has this issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •