Results 1 to 11 of 11

Thread: Faulty Ritek DVDs from Scan

  1. #1
    Registered User
    Join Date
    Mar 2006
    Posts
    9
    Thanks
    0
    Thanked
    0 times in 0 posts

    Faulty Ritek DVDs from Scan

    I bought a pack of 50 Ritek 'grade A' DVD-Rs from Scan, approx 3-4 weeks ago. I took a bunch of my DVDs backed up on holiday + laptop, and was disappointed to see that ALL of them stopped playing about half way through. I thought that it might be my laptop (Acer), so I've tried playing on a Dell laptop and on my standalone DVD player, same problem. Tried backing up on the Dell laptop, and the problem still occurs. So I think it's the discs.

    Tonight, I've tried to backup my Casino DVD about 5 times, and each time, the DVD comes out faulty and stops half way through when I try to play it, disc unreadable. Tried backing up with a Sony DVD bought from the in-my-opinion-very-overpriced PC World, no problems, plays perfectly. I have about 30 Ritek discs left, and I've tried them from the top, bottom and middle of the pile. All faulty. Yeah, I have the original Casino DVD, but I don't want to take it on the road with me and it get knackered. But that's beside the point...

    Will I be able to send these back for a replacement or refund? I went and chucked the 20 or so away, but I still have the pile of about 30 left. 1 faulty DVD out of 50 is unreasonable, but here it seems like the whole stack is faulty. I'll look for the receipt later, although a record of the purchase should still be on Scan's computers.

  2. #2
    Taz
    Taz is offline
    Senior Member Taz's Avatar
    Join Date
    Jan 2005
    Location
    London
    Posts
    2,112
    Thanks
    49
    Thanked
    26 times in 25 posts
    • Taz's system
      • Motherboard:
      • Gigabyte Z270 HD3P
      • CPU:
      • Intel Core i5 7600K
      • Memory:
      • Corsair CMK16GX4M2B3200C16R Vengeance LPX 16 GB
      • Storage:
      • Samsung 960 EVO M.2-2280 500GB (PCIe) + 1TB Sandisk Ultra II SSD (SATA)
      • Graphics card(s):
      • Asus NVIDIA GeForce GTX 1070 OC
      • PSU:
      • Corsair CS550M 550W Hybrid
      • Case:
      • NZXT Source 340
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • 34" Asus Designo Curve MX34VQ UWQHD Monitor
      • Internet:
      • Virgin Media Vivid 200
    It might just be a compatibility issue with your DVD writer. I went through several brands before settling on Datawrite DVD-R's for my LG writer - these work around 80% of the time on my burners. The eProformance range from Scan never worked at all - every single one failed to burn properly.

  3. #3
    Registered User
    Join Date
    Mar 2006
    Posts
    9
    Thanks
    0
    Thanked
    0 times in 0 posts
    Yeah, I've tried backing up on Acer and Dell laptops (different drive models), but without any success. I've had the Ritek discs from Scan before, and they worked perfectly -- that's why I bought the same again. As far as I know, bad discs usually come together... so this seems like a bad batch.

  4. #4
    MD
    MD is offline
    Ex-HEXUS.net Staff MD's Avatar
    Join Date
    Jan 2004
    Posts
    6,366
    Thanks
    18
    Thanked
    137 times in 60 posts
    • MD's system
      • Motherboard:
      • Asus P8Z77-M PRO
      • CPU:
      • i5 - i3570k
      • Memory:
      • 32GB Corsair Vengeance
      • Storage:
      • 2 x 256GB SSD's (Samsung and Crucial)
      • Graphics card(s):
      • NVidia 640
      • PSU:
      • Corsair 600W
      • Case:
      • Silverstone TJ08e MATX
      • Operating System:
      • Win 8
      • Monitor(s):
      • 24" Dell Flat Panel
      • Internet:
      • 60mb Virgin Media
    Its alos highly possible the discs got heat damaged, either at your holiday destination or if you were in the UK the heat over the past few weeks (esp yesterday) would have been difficult for any discs not protected from the sun....

    Matt.
    Please do not message me about Scan Free shipping, I no longer work for HEXUS.net

  5. #5
    Member
    Join Date
    Apr 2006
    Location
    Glasgow
    Posts
    195
    Thanks
    1
    Thanked
    4 times in 3 posts
    Ritek blanks can be a bit flaky at times. I have had similar problems with DVD writers not liking Ritek blanks. More so with the G05 blanks 8x speed blanks, the newer 16x speed disks have been better.

  6. #6
    Registered User
    Join Date
    Mar 2006
    Posts
    9
    Thanks
    0
    Thanked
    0 times in 0 posts
    Quote Originally Posted by Matt D
    Its alos highly possible the discs got heat damaged, either at your holiday destination or if you were in the UK the heat over the past few weeks (esp yesterday) would have been difficult for any discs not protected from the sun....

    Matt.
    The discs I took with me may have been damaged by the heat, but if so, they must be seriously poor quality as it wasn't that hot. However, I doubt it, because the blank ones (left at home in a drawer) I have left have problems at precisely 50%, or 80-90% upon dvd decrypter's verification check immediately after burning. No problems with my other discs left in the same drawer - the first bunch of Riteks that I bought from Scan. This batch of discs will play, but only to 50% or 80-90%, then the disc becomes unreadable.

    I trusted these discs because I bought them before from Scan, and there were no problems. So whats to do with these faulty discs...
    Last edited by kawanakya; 03-07-2006 at 03:06 PM.

  7. #7
    Senior Member chrestomanci's Avatar
    Join Date
    Sep 2004
    Location
    Reading
    Posts
    1,610
    Thanks
    92
    Thanked
    95 times in 79 posts
    • chrestomanci's system
      • Motherboard:
      • Asus AMD AM4 Ryzen PRIME B350M
      • CPU:
      • AMD Ryzen 1600 @ stock clocks
      • Memory:
      • 16Gb DDR4 2666MHz
      • Storage:
      • 250Gb Samsung 960 Evo M.2 + 3Tb Western Digital Red
      • Graphics card(s):
      • Basic AMD GPU (OSS linux drivers)
      • PSU:
      • Novatech 500W
      • Case:
      • Silverstone Sugo SG02
      • Operating System:
      • Linux - Latest Xubuntu
      • Monitor(s):
      • BenQ 24" LCD (Thanks: DDY)
      • Internet:
      • Zen FTTC
    I also have a pack of these Ritek blanks with I opened on Saturday, but did not use, so I am now wondering if I will have to sacrifice a few to testing before I can use them.

    It is also noticable that no one from Scan has posted to this thread, Normaly they reply fairly quickly to any posts in the Scan.care forum.

  8. #8
    Senior Member chrestomanci's Avatar
    Join Date
    Sep 2004
    Location
    Reading
    Posts
    1,610
    Thanks
    92
    Thanked
    95 times in 79 posts
    • chrestomanci's system
      • Motherboard:
      • Asus AMD AM4 Ryzen PRIME B350M
      • CPU:
      • AMD Ryzen 1600 @ stock clocks
      • Memory:
      • 16Gb DDR4 2666MHz
      • Storage:
      • 250Gb Samsung 960 Evo M.2 + 3Tb Western Digital Red
      • Graphics card(s):
      • Basic AMD GPU (OSS linux drivers)
      • PSU:
      • Novatech 500W
      • Case:
      • Silverstone Sugo SG02
      • Operating System:
      • Linux - Latest Xubuntu
      • Monitor(s):
      • BenQ 24" LCD (Thanks: DDY)
      • Internet:
      • Zen FTTC
    Quote Originally Posted by Matt D
    Its alos highly possible the discs got heat damaged, either at your holiday destination or if you were in the UK the heat over the past few weeks (esp yesterday) would have been difficult for any discs not protected from the sun....

    Matt.
    What is the maximum storage temperature for DVD blanks?

  9. #9
    Registered User
    Join Date
    Mar 2006
    Posts
    9
    Thanks
    0
    Thanked
    0 times in 0 posts
    Quote Originally Posted by chrestomanci
    It is also noticable that no one from Scan has posted to this thread, Normaly they reply fairly quickly to any posts in the Scan.care forum.
    Yes, they do seem to be ignoring this thread.

    However, the discs come with a 12 Month Warranty. I can see the label right in front of me. So how does that work?!

  10. #10
    mutantbass head Lee H's Avatar
    Join Date
    Dec 2003
    Location
    M28, Manchester
    Posts
    14,204
    Thanks
    337
    Thanked
    671 times in 580 posts
    • Lee H's system
      • Motherboard:
      • MSI Z370 Carbon Gaming
      • CPU:
      • Intel i7 8700K Unlocked CPU
      • Memory:
      • 16 GB Corsair Vengeance 3200 LPX
      • Storage:
      • 250GB 960 EVO + a few more drives
      • Graphics card(s):
      • 6GB Palit GTX 1060 Dual
      • PSU:
      • Antec Truepower 750W Modular Blue
      • Case:
      • Corsair 600T White Edition
      • Operating System:
      • Windows 10 PRO
      • Monitor(s):
      • 27" Asus MX279H & 24" Acer 3D GD245HQ + the 3D glasses
      • Internet:
      • Virgin Media
    Please report these issues to returns at the following link who will be able to advise you all accordingly ;

    http://web6.scan.co.uk/Support/Query.ASP?QueryType=R

    Best Regards,

  11. #11
    3XS Support Manager Ben @ Scan's Avatar
    Join Date
    Jan 2006
    Location
    Bolton
    Posts
    755
    Thanks
    14
    Thanked
    29 times in 26 posts
    • Ben @ Scan's system
      • Motherboard:
      • Evga X58 Sli LE
      • CPU:
      • Intel Core I7 920@4.5Gig
      • Memory:
      • 6 Gig Corsair DDR3 1600
      • Storage:
      • 1 x Intel 80 Gig SSD & 2 x 1TB Samsung Spinpoint F1
      • Graphics card(s):
      • Nvidia GTX 580
      • PSU:
      • Corsair 1000 Watt
      • Case:
      • Silver Temjin 07 (Silverstone)
      • Operating System:
      • Win 7 Pro 64 Bit
      • Monitor(s):
      • 27" Iiyama
      • Internet:
      • 50mb Virgin Media
    Hi

    What speed are you trying to backup the movie? Some software ie: Nero Vision/Nero Recode will only work at 4 Speed or Lower due to the way it compresses the DVD while putting it on a disk it is sometimes the transfer rate of coversion straight to disk that causes the error..


    Regards
    Last edited by Chris P; 13-07-2006 at 03:26 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why don't you buy from Scan?
    By DR in forum General Discussion
    Replies: 568
    Last Post: 09-12-2009, 02:35 PM
  2. Scan far too good!!!!
    By ExceededGoku in forum SCAN.care@HEXUS
    Replies: 6
    Last Post: 08-03-2006, 10:33 AM
  3. Scan Order - Not Happy
    By t_aitch in forum SCAN.care@HEXUS
    Replies: 15
    Last Post: 30-11-2005, 06:40 PM
  4. a little praise for scan
    By asteroth in forum SCAN.care@HEXUS
    Replies: 1
    Last Post: 05-11-2005, 04:17 PM
  5. great service from scan but i think i have a faulty component
    By bigjonnyauk in forum SCAN.care@HEXUS
    Replies: 1
    Last Post: 14-02-2005, 10:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •