Results 1 to 16 of 16

Thread: Laptop wont display 'video' when using dual display (projector etc)

  1. #1
    Squeeler Vini's Avatar
    Join Date
    Jul 2003
    Location
    Sheffield
    Posts
    1,769
    Thanks
    44
    Thanked
    8 times in 8 posts

    Laptop wont display 'video' when using dual display (projector etc)

    We have in the office some laptops which work fine, as in:- they will show DVD on the Laptop screen and DVD on the Projector (or 2nd source) without a hitch.

    And others, which will, show the DVD playing on the laptop but display a black image on the 2nd source, or, if you choose to output solely to the 2nd source, will work fine, but obviously you have no visuals on the primary (laptop) so for presenting etc this aint too good.

    Is it something as serious as GFX Chips ability. I know mines an ATI Mobile 9100 and works flawlessly, but the one im working with at the minute which has issues is an Nvidia 5200 GO. I also know one other Nvidia Go system to have this issue.

    (but in the back of my mind have a feeling one of oour users who may be nvidia has it wrking)

    or is it down to codec's ?

    On the Nvidia struggly one, ive just uninstalled all codecs and installed KLite... This still hasnt helped. But i understand it could still be codecs.


    I installed WMP10 too, to see if that helped. No Joy...


    anyone got anything to offer?

  2. #2
    Does he need a reason? Funkstar's Avatar
    Join Date
    Aug 2005
    Location
    Aberdeen
    Posts
    19,874
    Thanks
    630
    Thanked
    965 times in 816 posts
    • Funkstar's system
      • Motherboard:
      • Gigabyte EG45M-DS2H
      • CPU:
      • Intel Core2Quad Q9550 (2.83GHz)
      • Memory:
      • 8GB OCZ PC2-6400C5 800MHz Quad Channel
      • Storage:
      • 650GB Western Digital Caviar Blue
      • Graphics card(s):
      • 512MB ATI Radeon HD4550
      • PSU:
      • Antec 350W 80+ Efficient PSU
      • Case:
      • Antec NSK1480 Slim Mini Desktop Case
      • Operating System:
      • Vista Ultimate 64bit
      • Monitor(s):
      • Dell 2407 + 2408 monitors
      • Internet:
      • Zen 8mb
    In the Troubleshooting tab of your display properties reduce the hardware acceleration slider until the video appears.

    There may be a better way of doing this through your cards drivers, but it is all to do with how the video overlay is handled.

  3. #3
    Squeeler Vini's Avatar
    Join Date
    Jul 2003
    Location
    Sheffield
    Posts
    1,769
    Thanks
    44
    Thanked
    8 times in 8 posts
    Quote Originally Posted by Funkstar
    In the Troubleshooting tab of your display properties reduce the hardware acceleration slider until the video appears.

    There may be a better way of doing this through your cards drivers, but it is all to do with how the video overlay is handled.
    if that works, it just proves the sheer greatness of ATI

    [e!] but it didnt. it has about 6 settings, anything after reducing the acceleration by 2, and i lose directx/direct draw/dvd playback. and those '2' notches do nothing

    ive just disabled 'enable write combining' and rebooting now.

    [e! x2] nope, still no worky

    if i can get hold of this 'maybe computer' and find out whether its ATI or Nvidia, i could have my solution.
    Last edited by Vini; 20-04-2006 at 10:24 AM.

  4. #4
    Does he need a reason? Funkstar's Avatar
    Join Date
    Aug 2005
    Location
    Aberdeen
    Posts
    19,874
    Thanks
    630
    Thanked
    965 times in 816 posts
    • Funkstar's system
      • Motherboard:
      • Gigabyte EG45M-DS2H
      • CPU:
      • Intel Core2Quad Q9550 (2.83GHz)
      • Memory:
      • 8GB OCZ PC2-6400C5 800MHz Quad Channel
      • Storage:
      • 650GB Western Digital Caviar Blue
      • Graphics card(s):
      • 512MB ATI Radeon HD4550
      • PSU:
      • Antec 350W 80+ Efficient PSU
      • Case:
      • Antec NSK1480 Slim Mini Desktop Case
      • Operating System:
      • Vista Ultimate 64bit
      • Monitor(s):
      • Dell 2407 + 2408 monitors
      • Internet:
      • Zen 8mb
    oh well, worked on our toshiba laptops when i can into this problem a while back.

    you could try MediaPlayer Classic http://sourceforge.net/project/showf...ease_id=403110

    View -> Options -> Playback -> Output

    Don't know what combination would work, but worth a shot. It's also a damned good media player

  5. #5
    Squeeler Vini's Avatar
    Join Date
    Jul 2003
    Location
    Sheffield
    Posts
    1,769
    Thanks
    44
    Thanked
    8 times in 8 posts
    tried MPC and VLC

    im happy to show users how to just output to one screen (that being the 2nd display)... mine works too

  6. #6
    Treasure Hunter extraordinaire herulach's Avatar
    Join Date
    Apr 2005
    Location
    Bolton
    Posts
    5,618
    Thanks
    18
    Thanked
    172 times in 159 posts
    • herulach's system
      • Motherboard:
      • MSI Z97 MPower
      • CPU:
      • i7 4790K
      • Memory:
      • 8GB Vengeance LP
      • Storage:
      • 1TB WD Blue + 250GB 840 EVo
      • Graphics card(s):
      • 2* Palit GTX 970 Jetstream
      • PSU:
      • EVGA Supernova G2 850W
      • Case:
      • CM HAF Stacker 935, 2*360 Rad WC Loop w/EK blocks.
      • Operating System:
      • Windows 8.1
      • Monitor(s):
      • Crossover 290HD & LG L1980Q
      • Internet:
      • 120mb Virgin Media
    Is the display mode set to clone or 2 displays? Try the opposite to what its set as (ive got a feeling clone should work but not 2 displays)

  7. #7
    Vive le pants! directhex's Avatar
    Join Date
    Jul 2003
    Location
    /dev/urandom
    Posts
    17,074
    Thanks
    228
    Thanked
    1,027 times in 678 posts
    • directhex's system
      • Motherboard:
      • MSI X99A Gaming 7
      • CPU:
      • Intel Core i7 5280k
      • Memory:
      • 32GiB ADATA DDR4
      • Storage:
      • Corsair Neutron XT 960GB
      • Graphics card(s):
      • MSI GTX 980 Gaming 4G Twin Frozr 5
      • PSU:
      • Corsair AX860i
      • Case:
      • NZXT H440
      • Operating System:
      • Ubuntu 17.10, Windows 10
      • Monitor(s):
      • Dell U2713HM
      • Internet:
      • FIOS
    This is caused by a limitation in the way your system's video driver handles overlay layers.

    When doing video in a fast, GPU-accelerated manner, the OS displays a large coloured block (using some colour that is highly unlikely to be used elsewhere), and the GPU then puts the video playback on top of the marked region. This is one reason why you can't just press printscreen to grab frames from video - you don't catch the overlay layer.

    The issue is that your drivers appear to only do overlay on one output at a time - not both. Decreasing your "acceleration" slider actually forces the OS to pretend you lack certain features - including overlay - making it do CPU-hungry software-based blitting instead of accelerated overlay playback.

    I don't have any bright ideas for fixing it on a Windows-based nVidia setup - I've got solutions for Linux-with-Intel though. That said, generally speaking, any driver which can do a pure display clone on both outputs should be fine (the problem happens where both displays need to be coordinated seperately rather than directly cloned)

  8. #8
    Squeeler Vini's Avatar
    Join Date
    Jul 2003
    Location
    Sheffield
    Posts
    1,769
    Thanks
    44
    Thanked
    8 times in 8 posts
    Quote Originally Posted by herulach
    Is the display mode set to clone or 2 displays? Try the opposite to what its set as (ive got a feeling clone should work but not 2 displays)
    tried both.

    ill give the drivers and update to see if that does owt.

  9. #9
    Seething Cauldron of Hatred TheAnimus's Avatar
    Join Date
    Aug 2005
    Posts
    17,147
    Thanks
    798
    Thanked
    2,151 times in 1,407 posts
    As directx said it might be overlay only suppported one one screen (the primary screen) by the driver, and the 5200, been a 200 aka crap this might well be the problem. Some codec's such as Real<ly bad>player only support output to the primary screen. Do you need it to be displayed on both? If not select both to be primary.

    Have you tried a display span? Some device drivers let you span a single monitor accross two displays. The reason this works where as two seperate monitors in windows dosen't is because of the way the graphics card handles the refresh rates of the displays.

    Other than that the only way would be to use software writing to the video system via standard GDI systems..... not nice.
    throw new ArgumentException (String, String, Exception)

  10. #10
    Vive le pants! directhex's Avatar
    Join Date
    Jul 2003
    Location
    /dev/urandom
    Posts
    17,074
    Thanks
    228
    Thanked
    1,027 times in 678 posts
    • directhex's system
      • Motherboard:
      • MSI X99A Gaming 7
      • CPU:
      • Intel Core i7 5280k
      • Memory:
      • 32GiB ADATA DDR4
      • Storage:
      • Corsair Neutron XT 960GB
      • Graphics card(s):
      • MSI GTX 980 Gaming 4G Twin Frozr 5
      • PSU:
      • Corsair AX860i
      • Case:
      • NZXT H440
      • Operating System:
      • Ubuntu 17.10, Windows 10
      • Monitor(s):
      • Dell U2713HM
      • Internet:
      • FIOS
    you ought to be able to force an unaccelerated software display mode in the advanced VLC settings - i don't have a windows host to test, but on Linux the list includes OpenGL, XVideo (overlay) and X11 (unaccelerated)

    that way you don't cripple the whole system, but get it to work in the short term

  11. #11
    Seething Cauldron of Hatred TheAnimus's Avatar
    Join Date
    Aug 2005
    Posts
    17,147
    Thanks
    798
    Thanked
    2,151 times in 1,407 posts
    Ctrl + S
    Video -> Output Modules | tick advanced options

    its worth saying with MPEG stuff, it crawls.
    throw new ArgumentException (String, String, Exception)

  12. #12
    Squeeler Vini's Avatar
    Join Date
    Jul 2003
    Location
    Sheffield
    Posts
    1,769
    Thanks
    44
    Thanked
    8 times in 8 posts
    Quote Originally Posted by TheAnimus
    Ctrl + S
    Video -> Output Modules | tick advanced options

    its worth saying with MPEG stuff, it crawls.
    Well, VLC running in Windows GDI mode (using the above) works... Is there a way to set this as a system wide setting for all video players or is VLC just too damn cool?

  13. #13
    Treasure Hunter extraordinaire herulach's Avatar
    Join Date
    Apr 2005
    Location
    Bolton
    Posts
    5,618
    Thanks
    18
    Thanked
    172 times in 159 posts
    • herulach's system
      • Motherboard:
      • MSI Z97 MPower
      • CPU:
      • i7 4790K
      • Memory:
      • 8GB Vengeance LP
      • Storage:
      • 1TB WD Blue + 250GB 840 EVo
      • Graphics card(s):
      • 2* Palit GTX 970 Jetstream
      • PSU:
      • EVGA Supernova G2 850W
      • Case:
      • CM HAF Stacker 935, 2*360 Rad WC Loop w/EK blocks.
      • Operating System:
      • Windows 8.1
      • Monitor(s):
      • Crossover 290HD & LG L1980Q
      • Internet:
      • 120mb Virgin Media
    you can turn off overlays in the performance-advanced section of the wmp options

  14. #14
    Seething Cauldron of Hatred TheAnimus's Avatar
    Join Date
    Aug 2005
    Posts
    17,147
    Thanks
    798
    Thanked
    2,151 times in 1,407 posts
    I'm assuming you've used nVidia stuff to set it too dualview mode?
    throw new ArgumentException (String, String, Exception)

  15. #15
    Squeeler Vini's Avatar
    Join Date
    Jul 2003
    Location
    Sheffield
    Posts
    1,769
    Thanks
    44
    Thanked
    8 times in 8 posts
    Quote Originally Posted by TheAnimus
    I'm assuming you've used nVidia stuff to set it too dualview mode?
    Not touched it, left it as default.

  16. #16
    Seething Cauldron of Hatred TheAnimus's Avatar
    Join Date
    Aug 2005
    Posts
    17,147
    Thanks
    798
    Thanked
    2,151 times in 1,407 posts
    ah that might well be the problem. Trouble free way of getting the drivers to play well.

    switch off laptop, plug in projector, switch on laptop, display properties -> adanvanced.

    Geforce 5200 tab -> "nView Display Settings" -> nView Display Mode, Dual View.
    throw new ArgumentException (String, String, Exception)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Death of video recorder finally played.
    By DR in forum Consumer Electronics
    Replies: 34
    Last Post: 23-11-2004, 11:59 AM
  2. Laptop Dual Screen...
    By streetster in forum Graphics Cards
    Replies: 4
    Last Post: 22-09-2004, 09:55 PM
  3. FX5950 Dual Display Preferences? Need help!
    By royce in forum Graphics Cards
    Replies: 1
    Last Post: 15-03-2004, 09:10 PM
  4. Dual Display?
    By Loyal in forum Graphics Cards
    Replies: 15
    Last Post: 13-11-2003, 03:48 PM
  5. Dual P3 vs P4 for Video Editing
    By Achaelus in forum PC Hardware and Components
    Replies: 14
    Last Post: 06-11-2003, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •