Results 1 to 3 of 3

Thread: CoolerMaster PSU 'chirping' problem ?

  1. #1
    Member
    Join Date
    May 2008
    Posts
    135
    Thanks
    4
    Thanked
    11 times in 4 posts
    • nick_h's system
      • Motherboard:
      • Gigabyte P67A-UD4 Intel P67
      • CPU:
      • Intel Core i5 2500K "Unlocked"
      • Memory:
      • 8GB (2x4GB) Corsair Vengeance DDR3 PC3-12800
      • Storage:
      • 60GB Corsair Force F60 + 6TB HD
      • Graphics card(s):
      • 1280MB EVGA GTX 570 SC
      • PSU:
      • Corsair 850W HX Modular
      • Case:
      • Coolermaster Cosmos S
      • Operating System:
      • Windows 7 Home Premium 64bit
      • Monitor(s):
      • Asus VG236H 23" + Benq 19" LCD
      • Internet:
      • Virgin 50mbit

    CoolerMaster PSU 'chirping' problem ?

    Hi all. I’ve just treated myself to a wel earned upgrade :
    Q6600
    Asus P5KC
    Corsair memory
    CoolerMaster 650W PSU
    I built the system Thursday night and I’m having problems with the PSU. It’s making a high pitched ‘chirping’ noise that changes in pitch depending on how much load its under at the time. It’s very annoying !
    I’ve worked in IT now for 10 years ( large corporate ) and I have to say I’ve never had a PSU make a similar sound.
    Its definatley not fan related.
    I’ve already sent a request in to Scan Technical. It’s too loud to live with.....
    Bit annoying when I spent so long getting the ables etc sorted 
    Nyone else had similar r can offer advice ?

    Cheers

  2. #2
    The late but legendary peterb - Onward and Upward peterb's Avatar
    Join Date
    Aug 2005
    Location
    Looking down & checking on swearing
    Posts
    19,381
    Thanks
    2,892
    Thanked
    3,403 times in 2,693 posts

    Re: CoolerMaster PSU 'chirping' problem ?

    At a guess it is a noisy transformer and/or a fault inthe regulator ccts. I'd RMA it. (Most likely it iis noise generated by the transformer as the pitch changes with load. Could be that the transformer isn't seated tightly on the cct board, or the transformer itself wasn't sealed properly at mfr.)
    (\__/)
    (='.'=)
    (")_(")

    Been helped or just 'Like' a post? Use the Thanks button!
    My broadband speed - 750 Meganibbles/minute

  3. #3
    Member
    Join Date
    May 2008
    Posts
    135
    Thanks
    4
    Thanked
    11 times in 4 posts
    • nick_h's system
      • Motherboard:
      • Gigabyte P67A-UD4 Intel P67
      • CPU:
      • Intel Core i5 2500K "Unlocked"
      • Memory:
      • 8GB (2x4GB) Corsair Vengeance DDR3 PC3-12800
      • Storage:
      • 60GB Corsair Force F60 + 6TB HD
      • Graphics card(s):
      • 1280MB EVGA GTX 570 SC
      • PSU:
      • Corsair 850W HX Modular
      • Case:
      • Coolermaster Cosmos S
      • Operating System:
      • Windows 7 Home Premium 64bit
      • Monitor(s):
      • Asus VG236H 23" + Benq 19" LCD
      • Internet:
      • Virgin 50mbit

    Re: CoolerMaster PSU 'chirping' problem ?

    Thanks peter. I've filled in the RMA form.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Silverstone ST75F psu problem
    By professorx in forum SCAN.care@HEXUS
    Replies: 5
    Last Post: 11-05-2007, 12:42 PM
  2. PSU Problem and RMA Question
    By Jay007 in forum SCAN.care@HEXUS
    Replies: 1
    Last Post: 19-04-2007, 02:33 PM
  3. PSU Problem?
    By kidzer in forum PC Hardware and Components
    Replies: 26
    Last Post: 02-12-2006, 04:59 PM
  4. Silverstone 0dB Fanless PSU
    By Carvahlo in forum Reader Reviews
    Replies: 6
    Last Post: 21-10-2004, 09:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •